Fastq manifest import error

Hello Q2 folks,

Hope you all are well. I am having issues importing some demultiplexed 18S data into qiime2-2023.5, and after a good while searching on the forum and troubleshooting, I keep getting the same error.

Here is the command:
qiime tools import --type 'SampleData[SequencesWithQuality]' --input-path q2_manifest_1-158.csv --output-path SHAI_18S_demux_1-158.qza --input-format PairedEndFastqManifestPhred33V2

And here is the error:
Traceback (most recent call last):
File "/home/heatherdeel/anaconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/q2cli/builtin/", line 266, in import_data
artifact = qiime2.sdk.Artifact.import_data(type, input_path,
File "/home/heatherdeel/anaconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/qiime2/sdk/", line 327, in import_data
return cls.from_view(type, view, view_type, provenance_capture,
File "/home/heatherdeel/anaconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/qiime2/sdk/", line 353, in _from_view
transformation = from_type.make_transformation(to_type,
File "/home/heatherdeel/anaconda3/envs/qiime2-2023.5/lib/python3.8/site-packages/qiime2/core/", line 58, in make_transformation
raise Exception("No transformation from %r to %r" %
Exception: No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

An unexpected error has occurred:

No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

See above for debug info.

Here are the things I've tried:

  • I've used .csv and .txt for the manifest file
  • I've tried PairedEndFastqManifestPhred33V2 and PairedEndFastqManifestPhred33
  • I did use vsearch to "guess" that the data are Phred33, but I also tried Phred64 and Phred64V2 input formats
  • I looked for weird characters, quotation marks, etc in the manifest file and found none (I attached it here)
    q2_manifest_1-158.csv (30.5 KB)
  • Tried using --type 'SampleData[PairedEndSequencesWithQuality]' (I think this might be an old type but I was trying anything)
  • I had $PWD in place of part of my manifest path, changed that to the full path instead

Can someone help to figure out what I am missing here?

I've also attached a txt with the first few lines of one of my fastq files in case that is helpful.
fastq_first_lines.txt (2.3 KB)

Thanks for your insight! It is probably something simple that I am just not seeing.


Hi @hdeel,

The first thing I noticed was that you're metadata file is in csv format and not tsv as outlined in the documentation. So, replace the commas with tab-space and try again.

Your manifest file also suggests to me that you are trying to import paired-end data, which means your command should look something like this:

qiime tools import \
  --input-path manifest.tsv \
  --input-format PairedEndFastqManifestPhred33V2 \
  --type 'SampleData[PairedEndSequencesWithQuality]' \
  --output-path paired-end-demux.qza


Hi Mike,

Thanks for your quick response!

This is what finally worked:
qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path q2_manifest_1-158.txt --output-path SHAI_18S
_demux_1-158.qza --input-format PairedEndFastqManifestPhred33V2

I must have only tried the PairedEndFastqManifestPhred33V2 input format with the csv file and not the txt file (my understanding is that txt and tsv are functionally the same).

Just took another pair of eyes I guess!


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.