Fasta metadata is not working

Hi,

I'm having 3 forward only files, and I want to obtain the table.qzv using:
qiime feature-table summarize
--i-table table.qza
--o-visualization table.qzv
--m-sample-metadata-file sample-metadata.tsv

When I created the metadata file, I', getting an error (despite the fact that I checked it using keemei):

There was an issue with loading the file metalachish.csv as metadata:

Invalid characters (e.g. '/', '\x00', '\', '*', '<', '>', '?', '|', '$') or empty ID detected in metadata index: 'NRPSToRL1,/home/eddie/Barak/lachish/319-NRPSToRL1_S319_L001_R1_001.fastq,forward'. There may be more errors present in this metadata. Sample/feature metadata files can be validated using Keemei: http://keemei.qiime.org

Can't understand what the problem is and will be happy for your help.

metalachish.csv (285 Bytes)

Thanks
Barak

Hi @barakdror,

The csv file you’ve attached is not a metadata file but rather the manifest file you probably used originally to import your reads.
If this was by accident, could you please upload the correct metadata file? If this is indeed the file you are using (though your input commands suggest that’s not the case) then you simply need to use the right metadata file :stuck_out_tongue: Also of help, which version of qiime2 are you using? There have been some important changes to regarding metadata files in the most recent version of qiime2.

2 Likes

Thanks for helping.
So I think I got confused with something.

I apply the attached manifest file for the initial importing of my fasta files. The output is this qiime2 artifact: single-end-demux.qza (see attached prt-scn). Capturemanifest.txt (487 Bytes)
With this output should go to this phase:

qiime demux emp-single
--i-seqs emp-single-end-sequences.qza
--m-barcodes-file sample-metadata.tsv
--m-barcodes-column BarcodeSequence
--o-per-sample-sequences demux.qza

or to the data2 phase? it's a bit confusing...

Thank you,
Barak

Hi @barakdror,

After re-reading your original message I think I understand what is happening a bit better.

It looks as you tried to use your manifest file as your metadata file. These are 2 separate items, both which are needed at different steps. Think of it this way, the manifest file which in your case is the metalachish.csv (and actually manifest.txt too) are instructions for qiime2 to import already demultiplexed reads. Once you have imported your reads and created the single-end-demux.qza you will no longer need that manifest file. You can follow the manifest import tutorial for more information. The metadata file is a separate file that contains more detailed information about your individual samples and you will need it throughout various commands downstream. Here is an example of what one should look like if you are using the latest version of qiime2. As you can see the two are very different files and Keemei is designed to validate the metadata file. If you haven’t already, It might be worth your while to have a look through one of the tutorials to see how a typical workflow might be used for you. See this tutorial for example which starts by describing the metadata file a bit more in detail.

Hope that helps!

2 Likes

Hi,

Thanks for the detailed explanation. I went over the tutorial and tried to apply the same (with the required moficiations) for my own data.
However, trying again to use the attached metadata file, I get this error:

(qiime2-2017.12) [email protected][nrps] qiime feature-table summarize \ [ 1:53pm]
--i-table table.qza
--o-visualization table.qzv
--m-sample-metadata-file metalachish.csv
qiime feature-table tabulate-seqs
--i-data rep-seqs.qza
--o-visualization rep-seqs.qzv
Plugin error from feature-table:
**> **
> "None of [Index(['ToRL1', 'ToRL2', 'LeRL2', 'LeRL1', 'ToRL3', 'LeRL3'], dtype='object')] are in the [index]"
> Debug info has been saved to /tmp/qiime2-q2cli-err-utqw8yny.log
Saved Visualization to: rep-seqs.qzv

Can't understand what seems to be the problem as the metadata sample names are the same as in the manifest file, therefore what can be the problem?

Thanks,
Barakmetalachish.csv (262 Bytes)

OK, I just used .txt metadata and it worked. Thanks for the above help!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.