Failure when attempting to filter samples from table.qza

Hi everyone,

As mentioned in my previous post, I have sequencing data from three separate runs that I want to merge into a single one.

As @thermokarst suggested, I have imported the three seqs.fna files and dereplicated each one individually. I now have three FeatureTable[Frequency] artifacts and three FeatureData[Sequence] artifacts. I have tried merging the three tables with the qiime feature-table merge command, however it won’t let me merge the tables since there are 3 duplicates present in one of the tables that have to be removed prior to merging.

I have tried filtering out these three samples from the table using the following command but it doesn’t seem to work:

qiime feature-table filter-samples --i-table table-1.qza --m-metadata-file mapping.tsv --p-where “SampleID=‘BRU.05322’, SampleID=‘BRU.03823’, SampleID=‘BRU.03805’” --p-exclude-ids --o-filtered-table filtered-table.qza

I have manually removed the three duplicates from my mapping file but can’t seem to get around removing them from the table.

The error that I get is the following:

Selection of IDs failed with query:

SELECT “#SampleID” FROM metadata WHERE SampleID=‘BRU.05322’, SampleID=‘BRU.03823’, SampleID=‘BRU.03805’ GROUP BY “#SampleID” ORDER BY “#SampleID”;

Could anyone point out where my code is wrong or suggest an alternative way?

Thank you!

Hey there @thextramile!

This is because the overlap-method parameter is set to error_on_overlapping_sample by default, you could always change it to one of the other options listed in the docs.

You don't need the --p-where portion for ID-based filtering, instead, just provide either a metadata file with all the samples you wish to keep, or, a metadata file with all the samples you wish to discard, and then specify the --p-exclude-ids param.

Hope that helps! :t_rex: :qiime2:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.