Fail of import custom Taxonomy file

Hello there!

I am trying to import a custom taxonomy file. The sequences got in fine, but I am having trouble here. I am using qiime 2021.11 running with conda.

Here is the command I ran:
qiime tools import
--input-path Amphibian-skin_bacteria_metadata_simple.txt
--output-path antifungal-tax.qza
--source-format HeaderlessTSVTaxonomyFormat
--type 'FeatureData[Taxonomy]’

My file looks like this (txt tab separated):

For some reason nothing happens, and no activities from conda appear on htop, even after an hour, while I get my sequences imported within seconds. I tried to find answers on other topics but it looks like no one had this problem? Any ideas?

Thank you and qiime has been amazing to use!

1 Like

Hello Pauline,

Welcome to the forums! :qiime2:

I wonder if this is the issue:

--type 'FeatureData[Taxonomy]’
            This symbol here ^

That symbol looks like a “Smart” quote and not a 'normal' quote. Try using the normal quote instead and see if the command is able to run.

1 Like

Wow, that was easy. It was indeed a fail on my part.
It worked, thank you so much @colinbrislawn !
I also had to change grom --source-format to --input-format
That's really crazy because I basically copy pasted the command for the sequence file (changing just the arguments that were needed) and it worked fine...
In any case thank you so much!!!

1 Like

Happy to help!

Word processors like Google Docs and MS Word can add these smart quotes :writing_hand:
Try using a 'text editor' instead :technologist:

1 Like