Errors when importing biomtable and tree files created by Ucluster into QIIME2

Thanks @karren_owl --- I found the culprit. q2-phylogeny is using scikit-bio behind the scenes to do the midpoint rooting --- I was reading up on the Newick file format (used to represent the tree here), check this tidbit out:

In this format, underscores are treated as spaces --- in order to include a literal underscore, you must precede the underscore with a single-quote '. You can also surround the entire ID with single quotes.

You can learn more about the format here:

1 Like

Hi Mathew,

I tried the qiime importing again using new biomtable and tree file with id quoted with single quotes. However, it runs to the same error again:
All feature_ids must be present as tip names in phylogeny. feature_ids not corresponding to tip names (n=515): ‘May12.50v_1549’ ‘Jul11.25v_4600’ ‘Jun22.0v_544
2’ ‘Aug5.50v_20401’ ‘May12.75v_1961’ ‘Jul11.50v_9708’ ‘Jul27.25v_4983’ ‘Jul27.50v_1972’

What does your updated tree look like? The quotes shouldn’t be showing up in skbio at all…

It looks like:
(((((('May12.50v_9315':0.03482,(('Jun22.75v_1205':0.07334,('Jul11.0v_7885':0.00053,('Jun22.0v_1022':0.04590,'Jul27.5v_6359':0.01931)0.442:0.00054)0.872:0.00053)0.982:0.03354,((('Jul11.50v_3904':0.07224,('Jul11.5v_1691':0.05089,'Aug5.75v_18546':0.03200)0.932:0.04150)0.885:0.03220,(((((('Jul27.50v_1972':0.00055,('Jun22.0v_2832':0.03786,'Jul11.50v_2380':0.04936)0.745:0.00379)0.999:0.08336,((((('May12.75v_1550':0.05003,' (11.7 KB)

Are you sure you have your files in order? I just successfully ran the core-metrics-phylo command from above using the feature table (from above) (UUID e43d8331-06d5-4444-8835-70bec0bacf56) and the tree you just posted — worked as expected. Make sure you have everything in order and give it a shot again!

I got it! I changed the IDs in the biomtable too and got that error. Apparently I only need to add quotes to the IDs in the tree file. Thanks!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.