errors importing joined demultiplexed sequences

Hi! I am a new user and I am having difficulties importing joined and demultiplexed sequences. I’m running Qiime2 installed with VirtualBox. I’ve already searched this problem in the Forum before, but I wasn’t able to find the solution in my case.

These are the commands I’m trying to use:

qiime tools import
–type ‘SampleData[JoinedSequencesWithQuality]’
–input-path merged-manifest-file.tsv
–output-path merged-demux.qza

I’ve checked the manifest file a several times and it 's correct. It is localed in the same directory as the demultiplexed sequences. But I always get the following error:

Importing ‘SingleLanePerSampleSingleEndFastqDirFmt’ requires a directory, not merged-manifest-file.tsv

So, I’ve also tried this:

qiime tools import
–type ‘SampleData[JoinedSequencesWithQuality]’
–input-path merged-manifest-file.tsv
–output-path merged-demux.qza
–input-format PairedEndFastqManifestPhred33V2

The last error disappears, but I get a new one:

No transformation from <class ‘q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33V2’> to <class ‘q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt’>

I’m not sure if the error comes from the input-format because it may be incorrect. I can’t find the way to make my commands work.
I have managed to import unjoined demultiplexed sequences before, but I am stuck trying to import the joined sequences in this case. Any advice would be appreciated.
Thank you so much!

Hello @SaraGajas
Welcome to the QIIME2 forum :qiime2: !
First, Importing is what I consider the hardest step of the QIIME2.

From what I see here, you are so close. I believe instead of the input format being PairedEndFastqManifestPhred33V2, I think it is SingleEndFastqManifestPhred33V2. Since the sequences were previously joined QIIME2 handles them as though they are single end reads
qiime tools import
--type ‘SampleData[JoinedSequencesWithQuality]’
--input-path merged-manifest-file.tsv
--output-path merged-demux.qza
--input-format SingleEndFastqManifestPhred33V2

Please let me know if this doesn't work and we will be sure to debug more!
Chloe :turtle:

2 Likes

It worked!! Thank you very much @cherman2! :grin:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.