Errors during transaction when installing QIIME2-2019.10

Update: On Ubuntu 18.04 LTS, I got same error which is I got on Ubuntu 14.04 LTS. Now, I solved. In my case, it was firewall. Not on my system, it was on my institute’s policy. I contacted to IT guys and asked them to check the firewall during my installation and they found so many addresses (even are blocked by their new firewalls (actually they said it is https something, I did not understand exactly but it was sort of firewalls). Anyway, IT guy released those address which cause the bad or failed handshaking and Now I installed Qiime2-2019.10 successfully both on Ubuntu 18.04 LTS and 14.04 LTS.

@yanxianl, if you are also in sort of institute, university or company, you can try contact IT guy on your workplace. maybe it will help.


Hi @junkim83, thanks for sharing your solution! Now I suspect that I may have the exact same problem as we just recently changed the network connection of our linux machine. I’ll get in touch with the IT department at our University and see what happens.

1 Like

Hi all,

I believe it is a network firewall issue for me as well. My IT guys said that the issue could be because of the new SSL decryptions recently implemented which is blocking some previously working access. I was able to natively install qiime2-2019.7 while off my work network just fine.


I contacted our IT department to place the Linux workstation under another network and everything is back to normal. So, yes, this’s a firewall problem at the institutional level. That’s why shutting down the firewall from the linux PC didn’t help. Thank you @ebolyen and @junkim83!


@yanxianl, Great to hear that!!!

1 Like

Thanks so much everyone! I’m glad it all worked out, and it was awesome seeing everyone work together to figure this out :smiley:


Please disregard my deleted message. I realized I was using the MacOS instead of linux .yml install directions instead. I am still interested in finding out how to update the conda version I have right now.

conda update -n base -c defaults conda

Collecting package metadata (current_repodata.json): done
Solving environment: done

==> WARNING: A newer version of conda exists. <==
current version: 4.7.12
latest version: 4.8.0rc0

Please update conda by running

$ conda update -n base -c defaults conda

#All requested packages already installed.

I think you are all set with the newest conda, the “latest” shown there is a pre-release candidate, not ready for prime-time. Maybe you have preview channels enabled in your conda deployment?

1 Like

I had the same problem. The relevant file was already downloaded and I could manually access the failed links in my browser. Nonetheless, the installation got aborted.
I then simply opened the offending script that terminated the installation:
and changed line 17 from SUCCESS=0 to SUCCESS=1 so that it would continue the installation even id the download failed, and voila! It worked.

On reflection, maybe I manually downloaded the file, I tried so many things…
Anyhow, I too am behind a university firewall, but could not get anyone from IT to look at the problem. And I did the installation in a windows subsystem for linux environment.