Error with using dada2 command with QIIME2 2018.8 [Errno 2]

dada2

(Carolina Chung) #1

I am running the following command on a computing server using a .qza file generated from a publicly available sequence dataset:
qiime dada2 denoise-single

But I get the following error:
OSError: [Errno 28] No space left on device

I tried fixing this by changing the temporary directory, but then I got a new error:
Plugin error from dada2:
[Errno 2] No such file or directory: ‘run_dada_single.R’

Does anyone know how I can fix this issue?


(Matthew Ryan Dillon) #2

(Matthew Ryan Dillon) #3

Hey there @chechung!

Without the full error log it is hard to say if your tmp dir ran out of space, or the partition backing your current working dir.

Can you run the following and provide the output here?

df -h

This sounds like your “fix” actually broke something else unrelated. Can you let us know how you changed your temp dir?

Thanks! :qiime2: :t_rex:


(Matthew Ryan Dillon) #4

(Carolina Chung) #5

Hi @thermokarst

Here’s the output I get after running df -h:

And this is how I changed my tmp dir:
export TMPDIR=/home/user/Documents/temp

I’m fairly certain that it’s not an issue with how I changed the tmp dir. I suspect the second error I’m getting might have to do with how files are stored and deleted from tmp dir when running the dada2 command


(Matthew Ryan Dillon) #6

Hmm, that looks okay…

This looks okay too…

I don’t think that is the case, that file isn’t moved around at all as part of the tmp dir population process — the error above is a strong indication that your conda env has been corrupted (or, some relevant environment variables like PATH and PYTHONPATH have changed) — the file run_dada_single.R is a script distributed with q2-dada2, and is bundled as part of the installation of that plugin in your conda env. If python can’t find that file it likely either means the source file was removed from the deployment, or, the env vars were tweaked.

I agree, in general, but the reason I asked was in case you did something atypical here, like tried hacking your environment variables or making symbolic links, which could cause the corrupt env conditions I just mentioned above.

One way to check if that file is there or not is to run the following:

# activate your QIIME 2 conda env
ls $CONDA_PREFIX/lib/python3.5/site-packages/q2_dada2-*.egg-info/scripts

This should return something like the following:

run_dada_paired.R run_dada_single.R

If that command fails for some reason you can always just navigate to that directory manually, using your favorite tool.

How about you uninstall this conda env and redeploy QIIME 2? I know that is a pain, but I suspect that is the easiest course of action. If you do want to try and further debug, how about you run the following and send the results our way (make sure to edit out any sensitive info — BTW, it doesn’t look like you fully redacted your image above, there is information about your homedir in there):

env
# activate your QIIME 2 conda env
env
# this should give us a "before" and "after" picture (w.r.t. the conda env)

Keep us posted! :t_rex: :qiime2:


(Carolina Chung) #7

Hi @thermokarst

Thank you for your help. I was able to resolve my issue by installing QIIME2 using VirtualBox (I was using a version of QIIME2 available through a virtual machine, which I believe had an incomplete conda environment installed).