error with run_dada_paired.R --> not a valid sequence table

Hello! I am currently working on the DADA2 step in the qiime2 workflow. My data was already demultiplexed prior to qiime2 analysis (data was retrieved from SRA repository, so the details i have about the data is info provided on SRA as well as the paper). i successfully loaded the data as an artifact and was able to summarize it to look at the average quality over the reads to instruct my dada2 parameters. I then input the data with the following parameters into DADA2

qiime dada2 denoise-paired --i-demultiplexed-seqs pe-demux.qza --p-trunc-len-f 20 --p-trunc-len-r 20 --o-table table.qza --o-representative-sequences rep-seqs.qza --o-denoising-stats denoising-stats.qza --verbose

I have tried to run it a few times and am consistently getting this error:

Input must be a valid sequence table.
Calls: removeBimeraDenovo -> isBimeraDenovoTable
Execution halted
Traceback (most recent call last):
File "/data/apps/extern/anaconda/envs/qiime2/2022.2/lib/python3.8/site-packages/q2_dada2/", line 279, in denoise_paired
File "/data/apps/extern/anaconda/envs/qiime2/2022.2/lib/python3.8/site-packages/q2_dada2/", line 36, in run_commands, check=True)
File "/data/apps/extern/anaconda/envs/qiime2/2022.2/lib/python3.8/", line 516, in run
raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['run_dada_paired.R', '/tmp/tmplppuhq62/forward', '/tmp/tmplppuhq62/reverse', '/tmp/tmplppuhq62/output.tsv.biom', '/t
mp/tmplppuhq62/track.tsv', '/tmp/tmplppuhq62/filt_f', '/tmp/tmplppuhq62/filt_r', '20', '20', '0', '0', '2.0', '2.0', '2', '12', 'independent', 'consensus', '
1.0', '1', '1000000']' returned non-zero exit status 1.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/data/apps/extern/anaconda/envs/qiime2/2022.2/lib/python3.8/site-packages/q2cli/", line 339, in call
results = action(**arguments)
File "", line 2, in denoise_paired
File "/data/apps/extern/anaconda/envs/qiime2/2022.2/lib/python3.8/site-packages/qiime2/sdk/", line 245, in bound_callable
outputs = self.callable_executor(scope, callable_args,
File "/data/apps/extern/anaconda/envs/qiime2/2022.2/lib/python3.8/site-packages/qiime2/sdk/", line 391, in callable_executor
output_views = self._callable(**view_args)
File "/data/apps/extern/anaconda/envs/qiime2/2022.2/lib/python3.8/site-packages/q2_dada2/", line 292, in denoise_paired
raise Exception("An error was encountered while running DADA2"
Exception: An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

Plugin error from dada2:

An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

See above for debug info.
Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_paired.R /tmp/tmplppuhq62/forward /tmp/tmplppuhq62/reverse /tmp/tmplppuhq62/output.tsv.biom /tmp/tmplppuhq62/track.tsv /tmp/tmplppuhq62/filt_f /tmp/tmplppuhq62/filt_r 20 20 0 0 2.0 2.0 2 12 independent consensus 1.0 1 1000000

I found a forum question that pointed to the number of threads being used as a possible explanation, but i have reduced the threads from 24 to 6, and am still getting the same error.
I am running qiime2 on an HPC with Qiime natively installed (not in my own personal conda environment).

Thanks for helping!

Hello @Haley_Hallowell,

Do you mind sharing the "pe-demux.qza" file here?


Sure! It is about 9Gs .. uploading now!

hi @colinvwood , it was a bit too big to upload so i popped it into my google drive here pe-demux.qza - Google Drive

Hi @Haley_Hallowell,

We noticed that you are passing a length of 20 to the --p-trunc-len-f and --p-trunc-len-r flags. This means that you are allowing the sequences to be at most 20 bases long. Is this what you intended? This may be causing the error.


Hi @colinvwood,

Okay, that may be it. What i thought that option was denoting was how many basepairs to trim off of the sequence. Definitely want my reads more than 20bp long :smile:

I will fix and update shortly


No worries! Yes, trim and truncate are distinct.


hi @colinvwood I changed the parameters to fit the data (like 280,220) and its been running for about 12 hours now. I think that most definitely fixed the problem. Thank you for your help!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.