Error while running the denoising step in DADA2 - Plugin error from DADA2

Hi everyone,
I have 3 samples from 16S rRNA gene sequenced in Illumina. I had successfully imported and trimmed primer sequences from my data but I am stuck at the denoising step. I tried so many things as suggested in the forum but still I am getting error in this step. Please help me with this.
The command I ran is:

qiime dada2 denoise-paired
--i-demultiplexed-seqs trimmed_seq.qza
--p-trunc-len-f 0
--p-trunc-len-r 0
--p-trunc-q 20
--p-chimera-method pooled
--p-min-fold-parent-over-abundance 2
--o-table FeatureTable.qza
--o-representative-sequences Rep_seq.qza
--o-denoising-stats DADA2Stats.qza
--p-n-threads 10
--verbose

I am pasting the screenshot for the error. Please help me identify the problem in this step. I will be very grateful to you.

Hi @Naina_kumari,

Welcome to the :qiime2: forum!

The first screenshot you provided is quite blurry and difficult to read - could you please re-run your command above and simply copy/paste the results from your terminal in your response? Thanks! :lizard:

1 Like

Hi Lizgehret,
This time I ran the command I got the following without generating any output file:

(qiime2-2022.2) [[email protected] Aswini_metagenome_data]$ qiime dada2 denoise-ptiplexed-seqs trimmed_seq.qza --p-trunc-len-f 0 --p-trunc-len-r 0 --p-trunc-q 20thod pooled --p-min-fold-parent-over-abundance 2 --o-table FeatureTable.qza --o-sequences Rep_seq.qza --o-denoising-stats DADA2Stats.qza --p-n-threads 10 --verbose

Running external command line application(s). This may print messages to stdout
The command(s) being run are below. These commands cannot be manually re-run as d on temporary files that no longer exist.

Command: run_dada_paired.R /tmp/tmpin90kn13/forward /tmp/tmpin90kn13/reverse /tmutput.tsv.biom /tmp/tmpin90kn13/track.tsv /tmp/tmpin90kn13/filt_f /tmp/tmpin90kn 0 2.0 2.0 20 12 independent pooled 2 10 1000000

R version 4.1.1 (2021-08-10)
Loading required package: Rcpp
DADA2: 1.22.0 / Rcpp: 1.0.8.3 / RcppParallel: 5.1.5

  1. Filtering Terminated

Hi @Naina_kumari,

Thanks for following up and providing those details! @thermokarst pointed out that there is a SIGTERM error in the first screenshot you provided, which typically occurs when you have exceeded your resource allocation (assuming you are running QIIME 2 on some sort of cluster or server). I would recommend reaching out to your sysadmin for assistance in job submission to make sure you are requesting enough ram from your queuing system.

Hope this helps!

Cheers :lizard:

Thank you @lizgehret for your help.
I will try contacting my sysadmin. Hope it solves my problem.

Regards
Naina

1 Like