Error when trying to install Qiime - SpecNotFound: Invalid name, try the format: user/package

I did search for my error on the forum, and the only hit was for March '19, with an earlier version of Qiime, so I want to post my question.

When I type this command: conda env create -n qiime2-2020.8 --file qiime2-2020.8-py36-linux-conda.yml

I get this error: SpecNotFound: Invalid name, try the format: user/package

Here are screenshots:


How can I fix this?

Hi @jaff!

You will have to use something like the Windows Subsystem for Linux, instead of your Windows installation of anaconda. We don’t support running QIIME 2 directly on Windows, you have to use some form of virtualization (like the WSL, docker, or virtualbox)

Let us know what you decide to go with!

:qiime2:

1 Like

Why isn’t this mentioned on the Qiime 2 website? Or maybe it’s mentioned, but not in a way that novice users can understand…It was not clear to me from this site ( https://docs.qiime2.org/2020.8/install/native/ ) that I needed to first install yet another subsystem before doing any of the steps on the installation page.

Anyway, I will try the Windows Subsystem for Linux. Thanks.

1 Like

Hi @jaff!

Ah, sorry to hear that! There is a little bit of discussion on it here: https://docs.qiime2.org/2020.8/install/#recommendations. Support for WSL-based installations is brand-new for us, so expect to see some changes to the docs over the next few releases. In the meantime, feel free to suggest changes that would make it more clear to you, we would love some help on this!

1 Like

Hello,
I installed Ubuntu 20.04.01 LTS as my Windows Subsystem for Linux.
Then, I tried to install Qiime2 in the Ubuntu window, using these commands:
wget https://data.qiime2.org/distro/core/qiime2-2020.8-py36-linux-conda.yml
conda env create -n qiime2-2020.8 --file qiime2-2020.8-py36-linux-conda.yml
The wget command seemed to work, but I got an error when running the “conda env create” command:

So, I tried running the 2 commands in Anaconda powershell, but I got the same error as before I installed Ubuntu: “SpecNotFound: Invalid name, try the format: user/package”

I don’t understand what I’m doing wrong! Please help. Thank you.

Hi @jaff! You’re super close, the problem is you will now need to install conda inside the WSL Ubuntu VM. In the first screenshot you shared, in that terminal, follow the linux-based miniconda installation directions (similar to what you did to install anaconda on windows). Then you’ll have all the prereqs in order and should hopefully be on your way. Keep us posted.

I guess I don’t know how to install Anaconda “in that (Ubuntu) terminal.” When I click on the Linux installation of Anaconda, it seems to download the program just like before. But I will try…

Ok, so do I use the Linux installation:

OR…something else? Previously I used the Windows installation.

THANKS!

Yes indeed, you got it! Just remember to do it in the WSL Ubuntu terminal you shared above.

Ok, I opened the Anaconda file with Notepad, and I’m copying and pasting the code into Ubuntu. Let’s see if this works.

Ok, I have tried, and I can’t seem to install Miniconda3 inside of the Ubuntu terminal. I tried a lot of different things, but here’s one screen shot:

Help. :frowning_face:

Hi @jaff, sorry things aren’t going well for you. The screenshot about looks like you’re copying-and-pasting the miniconda installation file’s contents into the WSL shell — I don’t think that’ll work, though. I think in the WSL, you’ll need to download the installer, then run it, like this (the following is untested - I don’t have a Windows computer with the WSL available):

cd ~/
wget https://repo.anaconda.com/miniconda/Miniconda3-latest-Linux-x86_64.sh
chmod +x Miniconda3-latest-Linux-x86_64.sh
sh Miniconda3-latest-Linux-x86_64.sh
# follow the rest of the installation prompts, etc.
# once the installation is complete you'll have to launch a
# new wsl shell in order to get access to the newly installed
# conda tools.

We don’t develop miniconda (or the WSL), so our ability to help here is limited, but we can lend a hand where possible. If you’re looking for a quick, simple solution, maybe just install Virtualbox and use our official virtualbox package?

https://docs.qiime2.org/2020.8/install/virtual/virtualbox/

OMG, that worked!!! Thank you so much!

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.