Error using phylogeny plugin

After upgrading to qiime2-2020.6 and running the phylogeny plug-in, I found this error:

Error: QIIME 2 plugin 'phylogeny' has no action 'align-to-tree-mafft-fasttree\xa0--i-sequences'. Did you mean 'align-to-tree-mafft-fasttree'?

Here is the exact script I ran:

qiime phylogeny align-to-tree-mafft-fasttree --i-sequences DADA2_REP_SEQS.qza --o-alignment aligned-rep-seqs.qza --o-masked-alignment masked-aligned-rep-seqs.qza --o-tree unrooted-tree.qza --o-rooted-tree rooted-tree.qza

Where do the ‘xa0’ characters come from?

Edit: It seems to run with other scripts as well. I’m trying to re-arrange or manually edit the commands for the script to detect the problem.

Hi @emmzee,

can I ask you how did you run the command?
Did you run a script, typed, or copy-and-paste it from a document? Did this method worked before?
If it was copy-and-paste I would say the extra characters may be from the original document (e.g. some invisible Microsoft Words or similar).

Hope it helps
Luca

2 Likes

That actually turned out to be the issue, I was copying from my email. Thank you!

For anyone reading this post after the fact, the offending character is here:

This is a non-printing whitespace character, probably a bit of “fancy formatting” from the email @emmzee copied from.

2 Likes

To add to this, the extra character appears if copy-paste after you choose to apply the ‘plain text’ filter in Gmail.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.