Error "The rarefied table contains no samples or features".

Hi,

I am trying to perform the diversity analysis using:
qiime diversity core-metrics-phylogenetic --i-phylogeny rooted_tree.qza --i-table table.qza --p-sampling-depth 11547 --m-metadata-file sample-metadata.tsv --output-dir core_metrics_results

I used sampling depth 11547, the lower sampling depth after the denoising step.

I got the following error:
Plugin error from diversity:

The rarefied table contains no samples or features. Verify your table is valid and that you provided a shallow enough sampling depth.

Could you please help me with this?

Hi,

I was wondering whether the error was due to the metadata file I used.
I downloaded the file from the link: https://data.qiime2.org/2018.2/tutorials/moving-pictures/sample_metadata.tsv and it was saved as metadata.tsv.csv. The previous error occurred when uploading the metadata.tsv.csv file.

When I tried to trnsform it from .csv to .tsv format the following error occurred:

There was an issue with loading the file metadata1.tsv as metadata:

Found unrecognized ID column name ‘id,barcode-sequence,donkey,breed,year,month,day’ while searching for header. The first column name in the header defines the ID column, and must be one of these values:

Case-insensitive: ‘feature id’, ‘feature-id’, ‘featureid’, ‘id’, ‘sample id’, ‘sample-id’, ‘sampleid’

Case-sensitive: ‘#OTU ID’, ‘#OTUID’, ‘#Sample ID’, ‘#SampleID’, ‘sample_name’

There may be more errors present in the metadata file. To get a full report, sample/feature metadata files can be validated with Keemei: https://keemei.qiime2.org

Find details on QIIME 2 metadata requirements here: https://docs.qiime2.org/2020.2/tutorials/metadata/

I cannot detect where the error in the file is:

sample-id,barcode-sequence,donkey,breed,year,month,day
sample-DonkeyB1,TAGGCATG,Brown,2019,10,17
sample-DonkeyB2,CTCTCTAC,Brown,2019,10,17

Hi @E.Kamil,

If you are working through the Moving Pictures Tutorial, you will notice that sampling depth of 11547 is far greater than what is recommended in the tutorial, hence the error.

Please review the points regarding sampling depth in this section of the tutorial: https://docs.qiime2.org/2020.2/tutorials/moving-pictures/#alpha-and-beta-diversity-analysis

The problem you mentioned in your original post is specifically about your feature table or your sampling depth, not your metadata file. As stated in the error you included with your original post:

The rarefied table contains no samples or features. Verify your table is valid and that you provided a shallow enough sampling depth.

I’m a bit confused about your metadata question. You mentioned sample_metadata.tsv from the Moving Pictures tutorial, but the error you shared shows the contents of a completely different file. The issue seems to be unrelated to your original post in this topic.

I hope this helps!

Cheers,
Andrew

Hi @andrewsanchez,

Thanks a lot for your assistance!

I had two issues to solve. The error with the metadata table was solved. My basic error regarding that “the rarefied table contains no samples or features” was solved, after following the moving-pictures tutorial, as you indicated, but with entering sampling depth 2. Is this possible or I did something wrong during the previous steps?

Best regards,
Elena

A sampling depth of 2 will discard nearly all of your data. Can you walk me through your thought process about how you decided to go with a sampling depth of 2?

Perhaps if you share your demux summarize visualization (you can DM it to me if you aren’t comfortable sharing publicly), then we can figure what might be going wrong.

1 Like

Hi,

Thank you for your help!

Before applying my raw reads to DADA2 I had the following data:
Sample1: 35159; Sample2: 33039; Sample3: 27872; Sample4: 27133; Sample5: 26371; Sample6: 25536; Sample7: 24809; Sample8: 20160; Sample9: 20151; Sample10: 18898 and sample11: 17413.

I used the command: $ qiime dada2 denoise-paired --i-demultiplexed-seqs paired-end-demux.qza --p-trim-left-f 11 --p-trim-left-r 12 --p-trunc-len-f 150 --p-trunc-len-r 146 --o-table table.qza --o-representative-sequences rep_seqs.qza --o-denoising-stats denoising_stats.qza

The following results were extracted:


Could you please tell me what I do wrong?

Best regards,
Elena

Hi @E.Kamil,
Thanks for sharing all of those screen captures! Take a look at your DADA2 denoising-stats image - by reading across the columns from left to right, you can see the point at which you lost the great majority of your sequences.

When many sequences are lost during the “merge” process, it’s often because the forward and reverse sequences are not long enough after trimming, and so can’t be merged. You need ~20 bp of overlap between your forward and reverse reads in order to merge them. Generally, this means forward_length + reverse_length - 20 must be greater than or equal to the length of your target amplicon, which you can figure out based on the primer pair you used.

If sequences can’t be merged, DADA2 drops them. You can often remedy this by adjusting your trim/trunc parameters to yield longer forward/reverse read segments. If your reads still aren’t long enough to merge (e.g. you have a very long target amplicon), or if you lose too many reads because of quality, there are other approaches you can use (e.g. using forward reads only). Hopefully that won’t be necessary for you.

There’s a ton of information on DADA2 parameters on the forum - if anything’s unclear, take advantage of the “search” :mag: feature, and let us know how everything works out!

Best,
Chris :hedgehog:

4 Likes

To piggy back on Chris’s response, your quality scores are not completely terrible and you may be able to continue without trimming from the left of your reads and by using the full 150 truncation length to try and preserve the overlap.

2 Likes

Also just wanted to “QIIME” in here and say that current versions of q2-dada2 only need 12 nts of overlap.

2 Likes

Hi,

Thank you so much for your help @ChrisKeefe @Zach_Burcham and @thermokarst.
I followed your advise and tried to continue without trimming, without trimming from the left or with removing zero to eleven bases from the left and zero to five from the right. No improvement was observed. I imported my data, please see attached:demux.qzv (287.5 KB) .

Could you please help me some more with the DADA2 denoising parameters?

Thanks!

The primers I used for amplification were the V3-V4 (341F, 805R), and the amplicon created was expected to be approximately 460 bases. The program I applied to remove primers and adapters was Trimmomatic. The size of the amplicon after using Trimomatic was 150 x 2 bp (forward and reverse). Maybe the kit I used is not suitable enough for amplifying the selected area?

Hi @E.Kamil, if you used the V3-V4 primers and your amplicon size is around 460 bases then the issue is that 150bp paired-end sequencing will not have any overlap. For example, if the forward read starts at the 341bp position it will end around the 491bp position while the reverse read will begin at the 805bp position and end around the 655bp position. You can see that with this sequencing method there is a gap between the 491bp and 655bp positions and no overlap from your forward and reverse reads. Therefore, you will not be able to merge these reads. You may just have to use the forward reads and map only to the V3 region, but @ChrisKeefe or @thermokarst might have a better idea.

2 Likes

Unfortunately, @E.Kamil, I believe @Zach_Burcham is exactly right. 2x150bp = 300bp is much too short to join reads on an amplicon ~460bp in length. Using the forward reads might well get you workable results, though. Good luck, and let us know how it goes!

Hi @Zach_Burcham,

Thank you for your reply.

I was checking the extracted results from Trimmomatic. The results regarding sample 1 are the following: Input Read Pairs: 37262 Both Surviving: 27133 (72.82%) Forward Only Surviving: 741 (1.99%) Reverse Only Surviving: 7657 (20.55%) Dropped: 1731 (4.65%). The results from the other samples are similar. So the paired-end chemistry of illumina may provide the ability to identify and combine the forward and reverse reads, even with 150 bp fragments.

So I was wondering, is there anything else to try?

Thanks a lot!