Error occured after running command for denoising in dada2

Hi there,
I am using QIIME2-2020.8 , virtual box, in windows 16 24GB RAM. I ran the following command for denoising paired-end sequences:
qiime dada2 denoise-paired
–i-demultiplexed-seqs paired-end-demux.qza
–p-trim-left-f 0
–p-trim-left-r 0
–p-trunc-len-f 287
–p-trunc-len-r 240
–o-table table.qza
–o-representative-sequences rep-seqs.qza
–o-denoising-stats denoising-stats.qza
I got the error:
Plugin error from dada2:
An error was encountered while running DADA2 in R ( return code 1), please inspect stdout and stderr to learn more.
Debug info has been saved to /tmp/qiime2-q2cli-err-s54m4_01.log
How can I fix this error?
Thanks
Man

Hi, @Man :wave:

Please share the entirety of the error message you observed. There are a lot of details in there that will help us to advise you well. You might also find these other discussions about the same error helpful:

https://forum.qiime2.org/search?q=DADA2%20in%20R%20return%20code%20


Hi Andrew,
The full details of the error, I assume, is given below. I am using QIIME2-2021.2 version, RAM 24 GB.
Regards
MAN

Thanks for sharing your error traceback. I suspect you have an out of memory error, based on this line:
system call failed: Cannot allocate memory

Check how much memory you’ve allocated to the virtualbox. If your system has enough memory but VirtualBox only has access to 1GB or something, that will need to be changed.