Error: no such option: --m-barcodes-file

I am trying to demultiplex the multiplexed.qza file I created while importing my data. I keep getting the error “Error: no such option: --m-barcodes-file”. What am I doing wrong? I am running the current version of QIIME2 (2018.2). Here is my code thus far:

qiime tools import
–type MultiplexedPairedEndBarcodeInSequence
–input-path ~/Riley/AXRS/Fastq
–output-path ~/Riley/AXRS/Fastq/multiplexed-seqs.qza

qiime cutadapt demux-paired
–i-seqs multiplexed-seqs.qza
–m-barcodes-file ~/Riley/AXRS/RS_mappingfile_SCFAs_completed_study_only_w_responders.tsv
–m-barcodes-column BarcodeSequence
–o-per-sample-sequences ~/Riley/AXRS/Demux/demux.qza

Hello Riley,

According to the documentation, the flag should be
--m-forward-barcodes-file

Let me know if that works,
Colin

P.S. You can get Qiime 2018.4, if you want.

2 Likes

Hi Colin,
Thank you, I guess I have a couple questions:

  1. Do I need to upload separate files for the forward and reverse reads?
  2. Was this a change that was implemented when the version updated? In the qiime2 documentation, it only uses --m-barcodes-file…if so, it would be helpful if this was updated in the tutorials

Thanks!

Hi @rlhughes!

Nope, the method only supports demultiplexing reads with the barcode in the forward read.

No - this has always been the name of this parameter.

It looks like you are confusing the parameters in the two demux methods in the cutadapt plugin — the cutadapt demux-single method uses --m-barcodes-file, while cutadapt demux-paired uses --m-forward-barcodes-file. This is deliberate, because in the future we plan to support some form or forms of dual-index demux of paired-end reads - this could potentially require a reverse-barcodes parameter, so we are preemptively naming the forward parameter explicitly. Make sense?

1 Like

Got it, thank you so much for clearing that up!

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.