Error: No such command "types"


(Srinivasan Mahalingam) #1

I am running QIIME2 for buffalo vaginal microbial analysis. Now I am in the initial step of testing qiime2.

Options:
–version Show the version and exit.
–help Show this message and exit.

Commands:
info Display information about current deployment.
tools Tools for working with QIIME 2 files.
dev Utilities for developers and advanced users.
alignment Plugin for generating and manipulating alignments.
composition Plugin for compositional data analysis.
cutadapt Plugin for removing adapter sequences, primers, and
other unwanted sequence from sequence data.
dada2 Plugin for sequence quality control with DADA2.
deblur Plugin for sequence quality control with Deblur.
demux Plugin for demultiplexing & viewing sequence quality.
diversity Plugin for exploring community diversity.
emperor Plugin for ordination plotting with Emperor.
feature-classifier Plugin for taxonomic classification.
feature-table Plugin for working with sample by feature tables.
fragment-insertion Plugin for extending phylogenies.
gneiss Plugin for building compositional models.
longitudinal Plugin for paired sample and time series analyses.
metadata Plugin for working with Metadata.
phylogeny Plugin for generating and manipulating phylogenies.
quality-control Plugin for quality control of feature and sequence data.
quality-filter Plugin for PHRED-based filtering and trimming.
sample-classifier Plugin for machine learning prediction of sample
metadata.
taxa Plugin for working with feature taxonomy annotations.
vsearch Plugin for clustering and dereplicating with vsearch.

when I run the following command:
qiime types

I am getting the following error:
Usage: qiime [OPTIONS] COMMAND [ARGS]…

Error: No such command “types”.

Can you pls guide me


(Srinivasan Mahalingam) #3

Thanks @anwesh.
I followed this link for the qiime2 installation.
https://docs.qiime2.org/2018.11/install/
and I noticed that the QIIME 2 Core 2018.11 distribution includes the QIIME 2 framework, q2cli (a QIIME 2 command-line interface) and the following plugins:

  • q2-alignment
  • q2-composition
  • q2-cutadapt
  • q2-dada2
  • q2-deblur
  • q2-demux
  • q2-diversity
  • q2-emperor
  • q2-feature-classifier
  • q2-feature-table
  • q2-fragment-insertion
  • q2-gneiss
  • q2-longitudinal
  • q2-metadata
  • q2-phylogeny
  • q2-quality-control
  • q2-quality-filter
  • q2-sample-classifier
  • q2-taxa
  • q2-types
  • q2-vsearch
    and The Core distribution is necessary to run the command in qiime2. I am going right or not?

(Anwesh Maile) #4

Oh, I am sorry…
I was not aware of that…


(Matthew Ryan Dillon) #5

The q2-types plugin does not contain any commands, only formats, transformers, and semantic types used by other plugins. The error you saw is from q2cli, indicating as much.

For more info on which plugins are currently installed, please run qiime info - that will display all of the plugins currently installed, regardless of whether or not they have any Actions defined.

Keep on QIIMEin! :t_rex: :qiime2: