Error locating manifest file location

Hi there,
I have installed QIIME2 through virtual box and now trying to create absolute file path of my sample fastq files. My sequence files are on the desktop and in the folder “DVDa_gut_microbiome”. So, I used the following commands to get the absolute file path:

  1. cd Desktop
  2. cd DVDa_gut_microbiome
    However, after the second command, the following error showed up:
    bash: cd :DVDa_gut_microbiome: No such file or directory
    Can you help if I have made any mistakes here to get the absolute file path? Or please suggest if any other method can be used to get the absolute file path?
    Thanks
    Man

Hi, @Man! :wave: Welcome to the forum.

Firstly, have you seen this section of the importing data tutorial? There you can find details about how to define absolute paths in the manifest file. I suspect the approach outlined in the docs may be more manageable.

A question and suggestion:

  • What do you see when you type ls ~/Desktop?

You could use this brute force method to find the folder, if it is indeed somewhere on your desktop: find ~/Desktop -type d -name DVDa_gut_microbiome -print -quit 2> /dev/null. Or you can try find ~/ -type d -name DVDa_gut_microbiome -print -quit 2> /dev/null to search your home directory.

Lastly, are you sure that the directory with your fastq files is in the VirtualBox’s ~/Desktop folder? If those files are in fact on your host machine, you may want to look into configuring shared folders:

https://help.ubuntu.com/community/VirtualBox/SharedFolders

Good luck! Let us know if you have any more questions.

1 Like

Hi Andrew,
Thanks.
I have gone through the importing tutorials.
I realized that my files were located on the computer’s desktop, not on the VB’s desktop. So, I have dragged dropped my sequence files (I renamed them as Raw_sequences) and manifest file to the VB’s desktop. Now, I used the following commands to import these files:
qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path /home/qiime2/Desktop/Manifest_file_format.txt
–output-path paired-end-demux.qza
–input-format PairedEndFastqManifestPhred33
An error showed up saying:
There was a problem with the command:
(1/1?) no such option: -input-path/home/qiime2/Desktop/Manifest_File_format.txt.

image
Could you suggest what might have happened here?
Thanks
Man

The error:

(1/1?) no such option: --input-path/home/qiime2/Desktop/Manifest_File_format.txt.

is telling you that the option:
--input-path/home/qiime2/Desktop/Manifest_File_format.txt

does not exist. Which is true, it doesn’t. That is you forgot a space between --input-path and /home/qiime2/Desktop/Manifest_file_format.txt

1 Like