Error in the alpha-rarefaction step

Hi all,
I am trying to do the alpha-rarefaction step and encountered an error. I will briefly explain what I did as follows.
I did the DADA2 denoising to obtain the table.qza and rep-seq.qza files. I did the taxonomy assignment using the Silva database and also I did the filtering for the mitochondria, chloroplast, and unassigned reads. After the filtering step, I reviewed the table.qzv file to check the sampling depth. When I check the sample ID and sequence count table, I found that the last two samples have low sequence counts (from the bottom: 8043, and 8085). The third sample from the bottom of this table has a 10,157 sequence count. So, I selected the sampling depth as 8086 in my analysis.

After that, I used following command for the alpha-rarefaction:
qiime diversity alpha-rarefaction
--i-table table.qza
--m-metadata-file metadata.tsv
--o-visualization alpha-rarefaction-curve.qzv
--p-min-depth 10
--p-max-depth 8086

However, I had the following error:

All metadata filtered after dropping columns that contained non-categorical data.


I could not figure out this error to proceed with the analysis. So, I truly appreciate it if you could give me a possible solution for this error.

Thanks in advance!

Plugin is complaining, that you have only numerical columns in your metadata file.
To avoid this error, try to add categorical column tou your metadata file. It can be the source of the samples, treatment, location and any other categorical (text) parameter.

1 Like

Hi @timanix !
Thanks in advance for your prompt reply to my error. I will try to add the categorical column to my metadata file and run the analysis.

Thank you,

BTW, Here you can select 10,150 reads, since you are dropping last two samples, to increase amount of subsampled sequences. Or, choose 8040 (this is good as well!!!) to keep all samples with lower amount of subsampled reads.

1 Like

Thank you so much once again for your clarification for the sampling depth as well which is very helpful !!! I will try with those values to check my results.!

Kind Regards!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.