Error in manifest file q2 v.2021.8

Hello,

I am confused with the following while importing paired-end sequences through manifest file:

This happens in qiime2 v2021.8 (updated according to Natively installing QIIME 2 — QIIME 2 2021.8.0 documentation) using WSL (updated a few days ago) and Ubuntu 20.4. (installed a few days ago):

As you can see, I ran q2 v2021.8 and according to the documenation Importing data — QIIME 2 2021.8.0 documentation the manifest heading should be in the form:
sample-id forward-absolute-filepath reverse-absolute-filepath
(column names are tab separated)

However, the error message suggests to use older version of the manifest (I think it is for q2 2019 and older). In other words, to use .csv manifest format and sample-id,absolute-filepath,direction header

And finally, it did worked like that
image

Now, I'm interested in why it happens? Is this a bug in 2021.8. or something wrong with me?

If you need any addditional information, please don't hesistate to seek. Thank you.

Hi @Andrea_Mihajlovic ,

There are two types of manifest formats you can use for import, in your first attempt you used the newest type or version 2 (v2), in the second attempt the older type. Both are still valid and usable in the latest version of QIIME2, however, they require two different --input-format settings:
PairedEndFastqManifestPhred33V2 --> new format
PairedEndFastqManifestPhred33 --> old format

Hope is makes sense
PS are your sequences Phred33 or Phred64 (as you show in the failed attempt?)

Cheers
Luca

1 Like

Oh, that's the catch. I didn't know that V2 refers to manifest but rather sequences. Now, it's clear. We can choose between two versions with the format parameter.

Thank you for the very quick response :relaxed:

PS Our sequences are Phred33.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.