Error in fragment insertion

Hi everyone,
I ran this command to create a phylogenetic tree
qiime fragment-insertion sepp \

–i-representative-sequences rep-seqs-dada2.qza
–i-reference-database sepp-refs-silva-128.qza
–o-tree tree.qza
–o-placements tree_placements.qza
–p-threads 3
but after sometimes there was an error:

Plugin error from fragment-insertion:
Command ‘[‘run-sepp.sh’, ‘/tmp/qiime2-archive-5__ps0q_/0b32baf0-34ab-44c2-aeac-ad8172fc07f5/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘3’, ‘-A’, ‘1000’, ‘-P’, ‘5000’, ‘-a’, ‘/tmp/qiime2-archive-p8twu9h6/e44b5e78-31e5-4a0f-9041-494bc3ca2df2/data/aligned-dna-sequences.fasta’, ‘-t’, ‘/tmp/qiime2-archive-p8twu9h6/e44b5e78-31e5-4a0f-9041-494bc3ca2df2/data/tree.nwk’, ‘-r’, ‘/tmp/qiime2-archive-p8twu9h6/e44b5e78-31e5-4a0f-9041-494bc3ca2df2/data/raxml-info.txt’]’ returned non-zero exit status 1.

Debug info has been saved to /tmp/qiime2-q2cli-err-cu2dfcpc.log

I tried again but it didn’t work.
Thank you for your help.

Hi @mohsen_ej,
Have you tried searching the forum for key phrases from your error message? I found quite a few results that suggest you may have a resource issue. Try searching “fragment insertion non-zero exit status 1” and let us know what you think might be happening.

Best,
Chris :parrot:

3 Likes

Hi @mohsen_ej - @ChrisKeefe provides some great advice regarding searching the forum, but I also would like to ask for more information from you. The sepp command is unique in QIIME 2, it is one of the only known commands that requires specifically opting into emitting more debug information (because the underlying method slows down significantly when this debugging is on). We will need you to re-run with the debugging enabled for us to further help you:

qiime fragment-insertion sepp \
  --i-representative-sequences rep-seqs-dada2.qza \
  --i-reference-database sepp-refs-silva-128.qza \
  --o-tree tree.qza \
  --o-placements tree_placements.qza \
  --p-threads 3 \
  --p-debug \
  --verbose
2 Likes

Thank you @thermokarst and @ChrisKeefe . I’m waiting for the results and simultaneously reading the forum. a problem that I forgot to say is I had no problem with running that command with green gene classifier and this error has occurred when I wanted to create the phylogeny tree by silva classifier because I have read it is more accurate.
Thank you

Sorry @thermokarst. many thanks for your guidance but it’s about 50 hours that the command is running with no result. I have read in the forum that sometimes it takes longer but is there any way to know the remaining time for that? the RAM is 16GB but I set the virtual machine to use about 10GB already. I also, used Threads 3.
Thank you

Dear @thermokarst
Sorry, its still running. I chose threads 3 because my cpu has 4 threads and i tried to choose the most appropriate value for this. But when i check in performance monitor cpu is not struggling too much. Also, i didn’t choose anything in virtualbox setting about cpu and just set RAM. Is it possible that this long time processing is due to this reason or what? Can we estimate the remaining time of this step? I did it by greengene classifier in just 30 minutes is it natural that silva takes more than 7 days with same data?
Thank you

No, the reason it is taking a long time is because you enabled debugging, at my request above.

I'm sorry, I don't know.

Please be patient and let us know when its done!

:qiime2:

1 Like

Thank you for your answer Sir,
it is still processing after 9 days.

Sorry @thermokarst, it’s about 16days that processing “debug”. do you think is it possible?
thank you

Please see my last comment:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.