Error 'float' object has no attribute 'type' in OTU clustering


(Erin Lewis) #1

Hello,

I am trying to cluster OTUs in qiime and am getting the following error:

‘float’ object has no attribute ‘type’

I am running qiime2 2018.11 installed on Miniconda.

qiime vsearch cluster-features-de-novo \

--i-sequences /Users/xxx/Desktop/Data/qiime_tutorial_defaultdenoiseseqs.qza \
--i-table /Users/xxx/Desktop/Data/qiime_tutorial_defaultdenoisetable.qza \
--p-perc-identity 99 \
--o-clustered-table /Users/xxx/Desktop/Data/qiime_tutorial_defaultOTUtable.qza \
--o-clustered-sequences /Users/xxx/Desktop/Data/qiime_tutorial_defaultOTUseqs.qza \
--verbose

Traceback (most recent call last):
File “/Users/xxx/Desktop/miniconda3/envs/qiime2-2018.11v4/lib/python3.5/site-packages/q2cli/commands.py”, line 274, in call
results = action(**arguments)
File “”, line 2, in cluster_features_de_novo
File “/Users/xxx/Desktop/miniconda3/envs/qiime2-2018.11v4/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 199, in bound_callable
self.signature.check_types(**user_input)
File “/Users/xxx/Desktop/miniconda3/envs/qiime2-2018.11v4/lib/python3.5/site-packages/qiime2/core/type/signature.py”, line 301, in check_types
name, kwargs[name].type, spec.qiime_type))
AttributeError: ‘float’ object has no attribute ‘type’

Thank you!


(Evan Bolyen) assigned thermokarst #4

(Chris Keefe) unassigned thermokarst #5

(Chris Keefe) assigned ChrisKeefe #6

(Chris Keefe) #7

Thanks for speaking up, @erin13!
This should be an easy fix for you :crossed_fingers:, and your post helped us identify a couple of bugs.

Your argument to --perc-identity must be in the range 0-1.

We’ll be fixing up type-checking so that future users get helpful error messages (issue 1), and will look into solutions for displaying required parameter ranges so other people don’t run into this problem (issue 2).

Happy :qiime2:-ing!
Chris


(Chris Keefe) unassigned ChrisKeefe #8

(Erin Lewis) #9

Thanks for your help!

Erin