Error DADA2 denoising

Hey guys,

I have ran these commands before facing error on dada2:

Activated qiime2 through conda:
conda activate qiime2-2020.8

Ran fastqc:
fastqc -t 12 -o SRR068049.fastq.gz

Imported fastq to qza:
qiime tools import --type 'SampleData[SequencesWithQuality]' --input-path /work/microbiomapsi/liviacmg/bbMGYS0278/data --input-format CasavaOneEightSingleLanePerSampleDirFmt --output-path /work/microbiomapsi/liviacmg/bbMGYS0278/SRR068049.qza

Ran cutadapt (it is single-end):
Before run cutadapt, verified if there were the forward and reverse primers informed on the article:
grep -c "AGAGTTTGATCCTGGCTCAG" SRR068049.fastq
grep -c "TGCTGCCTCCCGTAGGAGT" SRR068049.fastq

(there were only the last one, this is why i cutted it)

qiime cutadapt trim-single --i-demultiplexed-sequences SRR068049.qza --p-cores 6 --p-front TGCTGCCTCCCGTAGGAGT --p-discard-untrimmed --p-minimum-length 200 --output-dir trim.cutadapt

Error trying to run dada2:
qiime dada2 denoise-single --i-demultiplexed-seqs trimmed_sequences.qza --p-trim-left 0 --p-trunc-len 230 --o-representative-sequences rep-seqs-dada2.qza --o-table table-dada2.qza --o-denoising-stats stats-dada2.qza --p-n-threads 4 --verbose

The output was this error:

Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_single.R /tmp/qiime2-archive-fnz3e6nu/8eabe224-00fb-4cca-8815-118b6ccdf44a/data /tmp/tmpqglsz62j/output.tsv.biom /tmp/tmpqglsz62j/track.tsv /tmp/tmpqglsz62j 230 0 2.0 2 Inf independent consensus 1.0 4 1000000 NULL 16

R version 3.5.1 (2018-07-02)
Loading required package: Rcpp
DADA2: 1.10.0 / Rcpp: / RcppParallel: 5.0.0

  1. Filtering .
  2. Learning Error Rates
    16560 total bases in 72 reads from 1 samples will be used for learning the error rates.
    Error in err[c(1, 6, 11, 16), ] <- 1 :
    incorrect number of subscripts on matrix
    Execution halted
    Traceback (most recent call last):
    File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/q2_dada2/", line 181, in _denoise_single
    File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/q2_dada2/", line 36, in run_commands, check=True)
    File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/", line 438, in run
    output=stdout, stderr=stderr)
    subprocess.CalledProcessError: Command '['run_dada_single.R', '/tmp/qiime2-archive-fnz3e6nu/8eabe224-00fb-4cca-8815-118b6ccdf44a/data', '/tmp/tmpqglsz62j/output.tsv.biom', '/tmp/tmpqglsz62j/track.tsv', '/tmp/tmpqglsz62j', '230', '0', '2.0', '2', 'Inf', 'independent', 'consensus', '1.0', '4', '1000000', 'NULL', '16']' returned non-zero exit status 1.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/q2cli/", line 329, in call
results = action(**arguments)
File "", line 2, in denoise_single
File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/sdk/", line 245, in bound_callable
output_types, provenance)
File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/qiime2/sdk/", line 390, in callable_executor
output_views = self._callable(**view_args)
File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/q2_dada2/", line 218, in denoise_single
File "/usr/local/miniconda3/envs/qiime2-2020.8/lib/python3.6/site-packages/q2_dada2/", line 192, in _denoise_single
" and stderr to learn more." % e.returncode)
Exception: An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

Plugin error from dada2:

An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

See above for debug info.

I discarded the option of memory problem because i tried to run on PBS on server and also tried to run on a newer version of qiime2. I also saw somewhere that it could be the R version, for the person it worked on R version 3.3, but i don't know if it is the problem or how to do this, because I think the R is automatically installed within conda.



Welcome to the forums! :qiime2:

Here's the core error:

I'm glad you checked the forums for this error and already illuminated eliminated issues with memory.
EDIT: I've got to stop using autocorrect

I notice you have one sample and 72 reads. That's quite small! Does this happen when you use a greater number of bigger samples?


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.