Emperor plots not showing on mac

Dear all,

I’m just going through the tutorials these days. I’ve got a problem with the emperor plots. I can see the right part where you can choose different parameters. It’s just the main plot is not showing up on Mac, which has happened with QIIME 1 too. I’m using Chrome and am sure I’ve enabled the WebGL. Any idea where is going wrong?


Good afternoon,

Well that’s strange. Let’s see if other Emperor plots work. Let me know what you see on this page. Can you see and rotate the plot?


1 Like

Hi Colin,

Thanks for the reply. I can not see the plot on the page you gave. I’s the same situation. I can choose the parameter on the right part, but the main plot is still not showing. This works well on my own laptop but it just would not work on the Mac in our lab.

Ah, we are making progress. Looks like the issue is with the web browser or the Mac.

Do you know if the Mac in the lab has updated to the newest version of Chrome?

There also might be some hardware limitations keeping that Mac from seeing the plots. How old is it?


Hi Colin,

I’m not sure when is the Mac bought, but the system is OS X 10.11.6 (15G1611). Graphics is ATI Radeon HD 5750 1024MB. The Chrome is updated to the newest. I came into this lab this September, and I remember that the emperor plots worked well on both Safari and Chrome at first. It’s just since one day it didn’t work any more. I can’t figure out what’s happening here.

Strange! I have no idea why it would suddenly stop working.

Let’s see if @yoshiki has any ideas.

@Qianhao_Li, can you see a rotating cube in this page:

Chrome has some ways to work around this, try going to chrome://flags/, then toggling the value in Override software rendering list Mac, Windows, Linux, Chrome OS, Android. You’ll need to restart the browser and try again (I would only try with the cube again). If you can’t, then I think the problem might be that your computer does not support WebGL.


I’ve set the Override software rendering list to enabled and I can see the rotating cube. But still I can’t see the emperor plots…

Hi @Qianhao_Li! How are you attempting to view your emperor plots? Are you using view.qiime2.org? Or qiime tools view? Could you please share a screenshot of what it is that you see when you load this visualization? Thanks! :t_rex:


I've tried with both the view.qiime2.org and command lines. Neither of them worked. I've attached the screenshot of the plot I got. Thanks for the help!

So the emper demo does not work, but the cube on https://get.webgl.org still works fine? This is so strange!

I feel like it’s a small setting, like WebGL was turned off or maybe your web browser is blocking the external scripts Emper needs to load. Do you see the https and the green lock :lock:? Do you have any plugins in your browser which may be blocking something?

Thanks for bearing with us while we try to solve this problem.

Hi Colin,

I tried to reset all the settings with Chrome and then make sure I enabled the WebGL and other things mentioned which are related to this. But still there is nothing showing up. I’ve checked and nothing is blocked. Maybe I just have to use my own computer everytime when I using the emperor plots…

Thanks for all your time and help.

Thanks for trying all these settings with me. I’m glad your emperor plots work well on your own computers. Unless @yoshiki has another suggestion, I think that’s our best option.

Let me know if you discover the solution,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.