Emperor from beta-diversity-alt

Hello, I’m trying to get Emperor plot from Generalized UniFrac results. I got the Generalized UniFrac results using this command: qiime diversity beta-phylogenetic-alt --i-table table_pick.qza --i-phylogeny rooted-tree.qza --p-metric generalized_unifrac --o-distance-matrix generalized_unifrac.qza. But when I run:

$ qiime emperor plot --i-pcoa generalized_unifrac.qza --m-metadata-file metadata_including_health_and_grouping.tsv --o-visualization generalized_unifrac_emperor
Plugin error from emperor:

  Argument to parameter 'pcoa' is not a subtype of PCoAResults.

So what’s the input format for qiime emperor plot, and which command to generate?
generalized_unifrac.qza is of type DistanceMatrix % Properties(['phylogenetic']).

I tried to find an answer by looking at the provenance of Emperor plots generated by core-metrics-phylogenetic but it doesn’t show the intermediate commands.

Thanks a lot,

Hi there @jjmmii!

You are providing a distance matrix as input here, which is why the viz is upset. You need to run a PCoA analysis on the distance matrix, then you use that result as input to the emperor plot command. Make sense? Let us know if you get stuck! :t_rex:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.