Demux with DADA2 in qiime2-2018.8

Hi,
I have mixed oriented reads from 16s sequencing. After removing the barcodes now I want run the demux command. What is the basis of trimming the sequences in DADA2 ? I ran this code-
qiime dada2 denoise-paired --i-demultiplexed-seqs /media/moloy/LaCie/bburg/expt2/pool1/alldemulti/demux_import.qza --p-trunc-len-f 0 --p-trunc-len-r 230 --p-trim-left-f 6 --p-trim-left-r 6 --p-n-threads 0 --o-table table --o-denoising-stats --output-dir stats --o-representative-sequences repseq–verbose
Here is the list of reverse primers that were used -
TCGCAGGACCGCGGCTGCTGGCAC
CTCTGCAACCGCGGVTGCTGGCAC
CCTAGGTACCGCGGCTGCTGGCAC
GGATCAAACCGCGGCTGCTGGCAC
GCAAGATACCGCGGCTGCTGGCAC
ATGGAGAACCGCGGCTGCTGGCAC
CTCGATGACCGCGGCTGCTGGCAC
GCTCGAAACCGCGGCTGCTGGCAG

and the forward barcodes-
TCGCAGG
CTCTGCA
CCTAGGT
GGATCAA
GCAAGAT
ATGGAGA
CTCGATG
GCTCGAA

yet what I am lacking to understand is the visualization part of the results for the demux command. I have none.Can someone kindly help.

Hi @amit!

Sorry if I don’t entirely follow,

What kind of files do you have? Are your reads interleaved (forward, then reverse, the forward, etc.) or are they in either direction at random (like IonTorrent)? Or do you simply mean that you have both forward and reverse?

Would you be able to provide the result of demux summarize? Generally there’s no perfect answer, but the goal is to clip off your reads with the quality scores drop in a consistent way. (Additionally you must remove the primers, so your --p-trim-left should probably at least 24 to entirely remove your primer.

Hope I understood correctly!

Hi @ebolyen,
They are mixed oriented reads meaning that the barcodes and primers can be in forward or reverse orientation. I tried using shell scripts to remove the barcodes and then removing the primers. amit.txt (6.1 KB)

The headers of the input files have been pooled into 1 and have 8 samples each. So they have to be first separated and worked on accordingly which I did. data.txt (3.5 KB)
Bt today when I tried doing the analysis using DADA2 (version 1.9.3) analysis it gave me an error while trying to make quality score plots. The error was -
plotQualityProfile(reverse_reads)
Error: internal: buf !=
So I started searching for this error and came across a thread in DADA2 forum-

So i tried the same on both the files for one sample SAE1903 among the others-
[1] “dada2.Rproj” “filtered” “SAE1903_demux_R1.fq” “SAE1903_demux_R2.fq”
[5] “SAE2000_demux_R1.fq” “SAE2000_demux_R2.fq” “SAE2103_demux_R1.fq” “SAE2103_demux_R2.fq”
[9] “SAE2203_demux_R1.fq” “SAE2203_demux_R2.fq” “SAE2303_demux_R1.fq” “SAE2303_demux_R2.fq”
[13] “SAE2403_demux_R1.fq” “SAE2403_demux_R2.fq” “SAE2603_demux_R1.fq” “SAE2603_demux_R2.fq”
[17] “SAE2803_demux_R1.fq” “SAE2803_demux_R2.fq”.
It gave me the following results error.txt (13.2 KB)
I am not an expert to interpret this error. Are there quality issues here ?
I am all so confused.
Kindly help.

Hi @amit

QIIME 2 doesn’t yet support that version of DADA2 yet, so it sounds like you aren’t using QIIME 2 to denoise, is that correct? If so, I am not sure if there is much we can do here to help.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.