Demux trouble in tutorials

I was running qiime2 tutorial and when I run demux:
[email protected]:~$ qiime demux emp-paired \

–m-barcodes-file sample-metadata.tsv
–m-barcodes-column BarcodeSequence
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux
–p-rev-comp-mapping-barcodes
There was an error message saying:
Error: no such option: --m-barcodes-column

Can you help me? thanks

Hi @cecibe,

I think you may be entering the command improperly.

Can you paste this in your terminal and see if that does the job:
qiime demux emp-paired --m-barcodes-file sample-metadata.tsv --m-barcodes-column BarcodeSequence --i-seqs emp-paired-end-sequences.qza --o-per-sample-sequences demux --p-rev-comp-mapping-barcodes

It appeared the same message:
[email protected]:~/qiime-atacama-tutorial$ qiime demux emp-paired --m-barcodes-file sample-metadata.tsv --m-barcodes-column BarcodeSequence --i-seqs emp-paired-end-sequences.qza --o-per-sample-sequences demux --p-rev-comp-mapping-barcodes
Error: no such option: --m-barcodes-column

Hi @cecibe,

The option that is giving you the error

Was an addition made during the most recent version of qiime2 2018.2.
It looks as though you are using version 2017.12 so that option is not recognized. You can either upgrade to the newest version (your best option) or if you can’t upgrade for some reason, you’ll need to adjust your command to fit the available options in the older version, meaning without the --m-barcodes-columnc tag.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.