Demux results in the loss of data


I am practicing 'atacama soil microbiome" tutorial using my data (paired sequencing data for 134 samples)
I think I made “emp-paired-end-sequences.qza” (2.63GB) but if I demux the file using following code,

qiime demux emp-paired
–m-barcodes-file sample-metadata.tsv
–m-barcodes-category BarcodeSequence
–i-seqs emp-paired-end-sequences.qza
–o-per-sample-sequences demux

qiime demux summarize
–i-data demux.qza
–o-visualization demux.qzv"

I ended up having demux.qza and demux.qzv whose size is only 123 KB and 293KB, respectively.
When I checked the qzv file in the, I found that It only had 53 samples (which was supposed to have 134 samples) and more than half of samples had only 1 sequencing counts.
I also double checked the metadata via Keemei and it said my metadata is ok.

So, could you please tell me what would be possible reasons (or solutions) for this issue?
I can send you my demux.qzv file (or any files) if you want to take a look at it.

Thank you so much in advance for your kind help!

Hi @scho73,

I suspect the issue is your barcodes are already in the correct orientation, so you shouldn’t be passing --p-rev-comp-mapping-barcodes. Try removing that flag, you’ll probably see the rest of your samples show up then.

Let us know if that works!

1 Like

Yes! It is working!
Thank you so much for your kind comment.

But, I have a question about the role of “–p-rev-comp-mapping-barcodes” flag.
I had looked at the tutorial but I could not find the explanation about the flag.

Could you please tell me what the flag does?
Thanks again!

Hi @scho73,
The --p-rev-comp-mapping-barcodes flag reverse complements the barcodes from the sample metadata file before attempting to demultiplex. This is sometimes required, depending on how the barcodes are sequenced. (As a side note, in the majority of cases has the same effect as the --p-rev-comp-barcodes parameter, which reverse complements the barcode reads during demultiplexing. If barcode error correction is being performed, which is not currently supported in QIIME 2, then these two parameters are not identical.)

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.