Deblur Trimming Errors

Hi. I am trying to Deblur with my Demux-ed sequences but I am receiving this error message

Plugin error from deblur:

  • No sequences passed the filter. It is possible the trim_length (10) may exceed the longest sequence, that all of the sequences are artifacts like PhiX or adapter, or that the positive reference used is not representative of the data being denoised.*

Debug info has been saved to /tmp/qiime2-q2cli-err-iw2es38i.log

These are my results from the demux.qzv:


And my command lines:

$ qiime deblur denoise-16S \

--i-demultiplexed-seqs demux-filtered.qza
--p-trim-length 10
--o-representative-sequences rep-seqs-deblur.qza
--o-table table-deblur.qza
--o-stats deblur-stats.qza

I have tried several other trim lengths but still receive the same error message? Am I doing something wrong here? Thanks in advance for your help!

Hi @YinXun,

It looks like your sequences are both of low quality and quite short. If you look at your quality plot or your table, you’ll see that 75% of your sequences have a quality score of 2. This is not high enough quality for analysis. I would recommend that you contact the source of your sequences and request that they re-run your data for free.


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.