dada2,unequal length amplicon

I tried to deal with a 30-140bp target sequence amplicon (P6 loop of plant trnl) with dada2 on qiime2, using pe150 strategy. How should I set the parameter p-trunc? When I set this parameter to 90 or 80, the length of the obtained feature sequences is greater than about 100-110bp, and there is no 30 or 40bp (this is wrong). How can I deal with this unequal length amplicon with dada2?

I found that the parameter minLen is in DADA2 in R, but the parameter in dada2 integrated in qiime2 is not set?

Do the bosses have any good suggestions for dealing with this unequal length amplicon?

Good afternoon!

When sequencing an amplicon shorter than your reads, it's possible that the correct overlap will be greater than 100%

30 bp amplicon  |---|
R1              |---------->
R2       <----------|

I'm not sure how dada2 deals with >100% overlap... :thinking:

I know that qiime vsearch join-pairs supports this kind of joining with the setting --p-allowmergestagger. You could try using that plugin for joining, and see if vsearch is able to give you joined amplicons of the correct length.

Let me know how that works!