DADA2 trimming step - no reads passed the filter

Hi everyone,

My lab mate and I are new to QIIME2 and we recently were able to upload our fastq files from an Illumina MiSeq machine in manifest format. We created the paired-end-demux.qza and .qzv files, and now we are on the DADA2 step.

Attached is a screenshot of our sequence quality plots (forward and reverse). For the forward reads, the quality increases at position 4, while in the reverse reads the quality is pretty good starting at position 1. For both the forward and reverse reads, the quality in positions 95 and 96 (the last 2 positions) gives a red error because there were only few reads that sequenced that far.

We have tried trimming using various trimming parameters, but keep getting the same error. Does anyone have any ideas of some appropriate trimming parameters that we can apply without getting this error? (screenshot of code with the error is also attached).

Thanks in advance!

Hi @cjone228,
The problem here is that your truncating parameters are set way low.
Given your parameters for example on your forward reads:
trim=3 and trunc=4 you are essentially instructing DADA2 to remove everything before (5’) of the position 3, and everything after position 4. You basically are discarding everything so no reads are passing the filter.
I think what you want is to set your trunc parameter to say 90, so as to remove the last 5 bp.
On a separate note, these appear to be fairly short reads in general, what is your target region? Are you sure they will overlap for dada2 to merge them?

1 Like

Hi @Mehrbod_Estaki, thank you so much for the reply! Yes, that was definitely an issue, and we fixed that now! We changed the parameters and DADA2 was running for about 5 days until it unfortunately came up with this error:


Does anyone have any idea what this means and how we could fix this?

Thanks in advance!

Hello Carli,

The clue in this new error is the return code -9. This means your job was killed (canceled) by the system… perhaps because your system ran out of RAM.

Dada2 can use a lot of RAM, and macbook airs only have so much. One think you can do (other than switch to a bigger computer), is to pass a smaller number for --p-n-reads-learn
By default this is 1 million reads
--p-n-reads-learn 1000000
but passing just 10k reads should reduce RAM usage a lot.
--p-n-reads-learn 10000

Let us know if this works!



Everything @colinbrislawn said :white_check_mark:.
I would also add the --verbose flag in case a new error pops up we can get more details about the error.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.