DADA2 (return code 1): dada_uniques

Hi there! I still get an error in dada2. I run 20 samples with the following command:

(qiime2-2018.2) [email protected]:~/MiSeqRun-180417-Pretest$ qiime dada2 denoise-paired \

–i-demultiplexed-seqs trimmed-seqs-180417_pretest.qza
–p-trim-left-f 0
–p-trim-left-r 0
–p-trunc-len-f 276
–p-trunc-len-r 260
–o-table table-dada2.qza
–o-representative-sequences rep-seqs-dada2.qza
–verbose

And it gives me out:

Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_paired.R /tmp/tmp5k2lifa7/forward /tmp/tmp5k2lifa7/reverse /tmp/tmp5k2lifa7/output.tsv.biom /tmp/tmp5k2lifa7/filt_f /tmp/tmp5k2lifa7/filt_r 276 260 0 0 2.0 2 consensus 1.0 1 1000000

R version 3.4.1 (2017-06-30)
Loading required package: Rcpp
DADA2 R package version: 1.6.0

  1. Filtering …
  2. Learning Error Rates
    2a) Forward Reads
    Initializing error rates to maximum possible estimate.
    Error in dada_uniques(names(derep[[i]]$uniques), unname(derep[[i]]$uniques), :
    Memory allocation failed.
    Calls: dada -> dada_uniques -> .Call
    Execution halted
    Warning message:
    system call failed: Cannot allocate memory
    Plugin error from dada2:

An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

I split the 20 samples in packages of 5 - and it worked for each of the four five packs. So it cannot be the dada trimm of values. Could you give me a hint how to solve the problem. Tahnk you so much. -Jul

(Here are the data specifications: raw data demultiplexed paired-end reads; qiime2: data input with Casava, pre-trimming of sequencing artifacts (primers etc.) with cutadapt trim-paired

qiime cutadapt trim-paired
–i-demultiplexed-sequences demux-paired-end-180417_pretest.qza
–p-front-f CCTACGGGNGGCWGCAG
–p-front-r GACTACHVGGGTATCTAATCC
–p-error-rate 0
–o-trimmed-sequences trimmed-seqs-180417_pretest.qza
–verbose
)

Hi @jul,

I think this is the issue. Usually its harder to know when a memory allocation fails, so we got lucky!

It looks like you are using an EC2 instance? If so what instance type? You will probably need a machine with ~16gb of RAM (more wouldn’t hurt if you want to be sure).

Perfect!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.