Dada2 merging issue - figaro- same number of sequence option - reg

My merging reads are not enough to go to downstream analysis with my 23s samples.

so wanted to test the best trimming option. but, the uneven nature of sequence length is not allowed to carry out the function.

Is there any plugin available to make my FAR & REV the same length with qiime.

Thank.

Hello @thinesh,

Welcome to the forums! :qiime2:

Would you be willing to post .qzv output from qiime demux summarize? That will tell us both the quality and read length distribution of your 23S samples, so we can see that trimming options could work well for you.

Also, what primers did you use to amplify the 23S region and how long do you expect your amplicons to be? This will let us calculate expected overlap, which is also helpful.

Dear Colin,

Thank you very much for your reply. Apologies for the late reply.

see the attached Demux.qzv.

(upload://rASbTB2XFaey6yxyn1bRECzS7bu.png)

https://view.qiime2.org/visualization/?type=html&src=bf384426-d664-4133-9eaf-415d6469511f

our primer as follows and expected 480 bp.

F- AATAACGACCTGCATGAAAC - 20
R- GCCTGTTATCCGTAGAGTAGC -21.

We are thinking of doing concatenation and following trimming. requires timing and learning new comment.

looking forward your suggestion to carry out this work with QIIMe.

Thanks.

Hello @thinesh,

Thanks!

Could you upload that file as an attachment? (The links are only viewable on your machine, so you have to share the .qzv file, not the link.)

demux_seqs.qzv (318.4 KB)

demux_seqs.qzv (318.4 KB)

find the attached. Looking forward your suggestion.

Thanks.

1 Like

Dear Colin,

Appreciate you kindly having a look and suggest me the future direction. Thanks.

OK, so...

You have 600 bp of coverage for a 480 gp amplicon. This means your area of overlap should be 120 bp of overlap without any trimming.

The bad news is that the quality drops at the end of R1 and drop a lot at the end of R2, so trimming will be required to get these to merge.

Try these dada2 settings:

--p-trunc-len-f 280
--p-trunc-len-r 220

Trimming locations in red :red_square:, overlapping area to join in blue :blue_square: :

This gives you 500 bp total, which means you have 20 bp overlap on your 480 bp read. Hopefully this removes enough low quality bases so they can merge, but it may be a challenge given the quality on R2.

EDIT: Also, you posted the same file twice. :thinking: Do you have a second file you would like me to look at?

1 Like

Dear Colin,

      Thanks for your suggestion. 

I tried as per your suggestion following the script.

qiime dada2 denoise-paired
--i-demultiplexed-seqs demux2_seqs.qza
--p-trunc-len-f 280
--p-trunc-len-r 220
--o-table table27.qza
--o-representative-sequences rep-seqs27.qza
--o-denoising-stats denoising-stats27.qza

As you mentioned, I did not get good result for many of my samples. I tried this combination also since i wanted to remove primer from the sequences.

qiime dada2 denoise-paired
--i-demultiplexed-seqs demux2_seqs.qza
--p-trim-left-f 20
--p-trim-left-r 21
--p-trunc-len-f 280
--p-trunc-len-r 220
--o-table table27.qza
--o-representative-sequences rep-seqs27.qza
--o-denoising-stats denoising-stats27.qza

What would be your next best option to get good result for my samples.

can i use alternative method for Alternative methods of read-joining in QIIME 2. [(Alternative methods of read-joining in QIIME 2 — QIIME 2 2022.2.0 documentation).

Looking forward your suggestion.

Thanks.

:+1: Nice!

Worth a try!

Keep trying other truncating settings and joining programs.

It's possible that your amplicon is so long and the quality so low that the reads on this run will be impossible to join. This is one of the problems with long amplicons. :crying_cat_face: In that case, you could consider importing only your forward read (because it has the best quality) and running dada2 denoise-single.

Let us know what you try next and what works for you.

Dear Colin,

Thanks for your suggestion.

As i mentioned i tried to do the alternative method. Since my sample is 23s i think i could not run this command (qiime deblur denoise-16S).

I tried different combination as per your suggestion but i loss around 80 samples out of 155 samples. ( file attached)
denoising-stats26.qzv (1.2 MB)

Me and my collaborators are worrying about the diversity loss if we use only use forward sequences.

We are thinking of using concatenation method to use the maximum sequences as possible.

Is there any option available to concatenate samples in QIIME?

Thanks.

Dear Colin,

   My question is regarding sampling depth. 

Have merged sequences from 1800-100. and few of them are 0.

What would be the ideal merged sequence depth i could select to carryout further analysis.

Regards.

metadata (1).tsv (11.0 KB)

Hello Thinesh,

Thank you for your patience.

I'm sorry to hear that you are still having trouble getting these reads to merge and pass filter. Based on the table you posted, it looks like many reads are being lost at both the quality filtering step and the merging step.

This is valid concern, as shorter sequence will have less taxonomic resolution. On the other hand, losing >40% of reads from every sample will also introduce bias, and this could be a bigger problem.

Using shorter sequences may be worthwhile if you can keep more of your reads and more of your samples. This decision is up to you. :thinking:

This is worth a try! I think some taxonomic classification programs may not like this method because if you cho_se to rem_ve the mid_le of a w_rd, it can be confusing.


I have seen papers published with as little as 1000 reads per sample, however that was a long time ago and having few reads reduces your statistical power / ability to detect changes between samples. So more reads are better!

Let me know if you can get more reads to pass filter using just your forward R1 reads.

1 Like

Dear colin,
Thanks for the reply. As i mentioned earlier i tried to concatenate sample. I did concatenate samples through Panda seq.

Then i imported concatenated sequences as a single end read. But, When i run the denoising command as follows
qiime dada2 denoise-single
--i-demultiplexed-seqs ./demux_seqs.qza
--p-trunc-len 480
--o-table ./dada2_table.qza
--o-representative-sequences ./dada2_rep_set.qza
--o-denoising-stats ./dada2_stats.qza

i got a error saying " Plugin error from dada2:

No reads passed the filter. trunc_len (320) may be longer than read lengths, or other arguments (such as max_ee or trunc_q) may be preventing reads from passing the filter"

Debug info has been saved to /tmp/qiime2-q2cli-err-t16901q1.log.

But when i run trun len 300 it runs.

qiime dada2 denoise-single
--i-demultiplexed-seqs ./demux_seqs.qza
--p-trunc-len 300
--o-table ./dada2_table.qza
--o-representative-sequences ./dada2_rep_set.qza
--o-denoising-stats ./dada2_stats.qza

Do you think my concatenation procedure is wrong or qiime wont accept the concatenated samples. Confused and trying to figure out to move forward.

Appreciate you to look at the Attached the Demux qzv and guide me to progress further.

demux_seqs.qzv (294.1 KB)

Thanks.

1 Like

I bet this is it. Qiime 2 expected reads to be joined or unjoined, and just sticking them end-to-end with concatenation is unexpected. I bet if you imported these reads without joining, then joined with dada2, you would get better results.

Let us know what you try next!

Thanks, colin. I understand.

Now I am trying to concatenate sequences using python script. then planning to import as a single-end sequence and compare the diversity difference between forwarding sequences and concatenate sequences. That will allow me to decide which is giving better results for my sample.

Will update the progress of my analysis.

Thanks.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.