DADA2: loss too many reads after filtering

Hi Qiime2 fellas,

I'm working with similar data (DNA extracted with PowerSoil, same primer pair, plus a organellar blocking primer set, Miseq sequencing),

I also lost a lot of data during dada2 step (see image below) even after trying all variations of metaparameters (FYI, I truncated fwd at 290 and rev 260, trimmed first 10 bp, this last one helped a lot),

I might sound mean, but with the combination of protocols we used, apparently we get low throughput, I even got a sample which only a 37% survived after all dada2 process.

Luis Alfonso.

Hi @Xinming_Xu,

Just checking in on this! Were the suggestions from @16sIceland and @WeedCentipede helpful for you, or do you need further assistance with this?


Hi Liz,

Sorry for the late reply. I decided to use no truncation and minimum overlap value even though it still loses many reads. But most of the samples still remain 20,000 reads. I assume it's still enough. Thanks for all your help!

1 Like

An off-topic reply has been split into a new topic: DADA2: losing a high number of reads after filtering

Please keep replies on-topic in the future.

Hi @timanix
Thank you for the information you provided in your answers, I'm new to qiime and bioinformatics and you have helped a lot. I was wondering if you could help me out with this same issue I am having.

So I used the 515F and 806RB primers and The V4 region is ~252 nts long. Add 39 (515F=19, 806R=20) bases of primers and you are up to 291 nts. I only have 2x150 = 300 nts of total sequencing, so just ~9 nts of overlap.

With the default -p-min-overlap setting I was getting near 0% merging, I then tried -p-min-overlap 6 and I'm getting much more merging. I tried truncating at 129 for forward read and 130 for reverse read, the merging is 60% to 80% but I have a lot of 40% and it is worrying me so I tried to truncate at 0 and I am getting much better merging. the quality after trimming the primers using cutadapt was not bad, do you think I should use trunc =0? or should I lower the min overlap some more and does lowering the minimum overlap affect the result negatively?

here are some pictures:
Truncating at 129 and 130

truncating at 0

quality of trimmed reads

length summary
length summary

Thank you!

Hi @Nayla_Higazy ,
Looks you already managed to get it working! If disabling truncating parameter by providing a 0 gives you better output, you should use it. Your last output looks fine to me as it is already and you can proceed with it.

If you still want to try to adjust the settings, I would:

  1. Set trunc parameter to 0 for forward reads and 140 for reverse with 4 bp as overlap
  2. Run with 0 for both trunc parameters and 4 as overlap
  3. Choose the best parameters from your settings you already run and a new ones.
1 Like

@timanix Thank you so much for your help and for replying so fast! In that case, I think I will proceed with my data right away.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.