DADA2 in R (return code -9), error

Hello, I run Dada2 using the following command i gotr the error. i already searched the forum but i cannot find a solution
(qiime2-2022.2) [email protected]:/media/sf_Qiime2$ qiime tools validate paired-end-demux.qza
Result paired-end-demux.qza appears to be valid at level=max.
(qiime2-2022.2) [email protected]:/media/sf_Qiime2$ qiime dada2 denoise-paired \

--i-demultiplexed-seqs paired-end-demux.qza
--p-trunc-len-f 187
--p-trunc-len-r 105
--o-table table.qza
--o-representative-sequences rep-seqs.qza
--o-denoising-stats denoising-stats.qza
Plugin error from dada2:

An error was encountered while running DADA2 in R (return code -9), please inspect stdout and stderr to learn more.

Debug info has been saved to /tmp/qiime2-q2cli-err-2otm4a50.log

Hello @Zango,

Here is the important part of the error:

Return code -9 means that the command was 'killed' / canceled by another program on your system. This can happen for many reasons, like on a cluster supercomputer when a job takes too long or on a laptop when a command uses too much memory.

Can you tell me more about the computer you are using to run Qiime2? How much RAM does it have, does it have a SLURM or TORQUE, stuff like that.


Thank you for the reply @colinbrislawn, iI am using my PC (window on virtual box) to run and the installed RAM is 16.0 GB (15.7 GB usable), i dont think there is anything like SLURM or TORQUE/
Thank you

Thank you for telling me more.

How much of that 16 GB have you allocated to your Qiime2 VM? How large is your input data set? For some tasks 15ish GB is plenty, but for larger data sets you may need more.

You could also try adjusting --p-n-reads-learn down from the default of
1000000 (1 million) to
100000 or even
10000 and see if the command will finish running with the memory you have on that machine.

I hope this helps. Let us know what you try next.

1 Like

I have 75 samples of about 438MB, i don't know how much RAM is allocated to the VM. The command you mentioned i dont really understand coz i am more of novice here.
Thank you

I used deblur denoising method and it run successfully, however when i run dereplication command i got the following error
(qiime2-2022.2) [email protected]:/media/sf_Qiime2$ qiime vsearch dereplicate-sequences \

--i-sequences demux-joined-filtered.qza
--o-dereplicated-table table.qza
--o-dereplicated-sequences rep-seqs.qza
Plugin error from vsearch:

Command '['vsearch', '--derep_fulllength', '/tmp/q2-QIIME1DemuxDirFmt-pp4vhzpb/seqs.fna', '--output', '/tmp/q2-DNAFASTAFormat-vfz5uhhn', '--relabel_sha1', '--relabel_keep', '--uc', '/tmp/tmpk0fdqs_c', '--qmask', 'none', '--xsize', '--minseqlength', '1', '--fasta_width', '0']' died with <Signals.SIGKILL: 9>.

Debug info has been saved to /tmp/qiime2-q2cli-err-94j2yhz_.log
Is this also cause by other program killing the process or because of my RAM, and how to fix it Please?

Yes, this is return code 9 again, 'signals: signal kill 9'. Another program is killing this process, possibly because of RAM usage.

Here's how to check on that and change it. It may look a little different on your machine:

Let me know if you can increase your memory allocation.

You are making good progress!

Following your recommendations, i successfully ran the commands.
Thank you!!!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.