DADA2 Help with "dada2 denoise-paired"

I have problem when using ‘qiime2-2019.7’.
Command: run_dada_paired.R /tmp/tmptpyuc_rh/forward /tmp/tmptpyuc_rh/reverse /tmp/tmptpyuc_rh/output.tsv.biom /tmp/tmptpyuc_r
h/track.tsv /tmp/tmptpyuc_rh/filt_f /tmp/tmptpyuc_rh/filt_r 150 150 0 0 2.0 2.0 2 consensus 1.0 40 1000000

R version 3.5.1 (2018-07-02)
Loading required package: Rcpp
DADA2: 1.10.0 / Rcpp: 1.0.2 / RcppParallel: 4.4.3

  1. Filtering Error in sendMaster(try(lapply(X = S, FUN = FUN, …), silent = TRUE)) :
    write error, closing pipe to the master
    Error in names(answer) <- names1 :
    ‘names’ attribute [84] must be the same length as the vector [82]
    Execution halted
    Traceback (most recent call last):
    File “/home/bio/anaconda3/envs/qiime2-2019.7/lib/python3.6/site-packages/q2_dada2/”, line 234, in denoise_paired
    File “/home/bio/anaconda3/envs/qiime2-2019.7/lib/python3.6/site-packages/q2_dada2/”, line 36, in run_commands, check=True)
    File “/home/bio/anaconda3/envs/qiime2-2019.7/lib/python3.6/”, line 418, in run
    output=stdout, stderr=stderr)
    What should I do?

Hi @PengGongxin,
Welcome to the forum!

Thanks for providing the full error message + qiime2 version, in the future please make sure to additionally provide us with the exact commands you’ve also used for troubleshooting purposes.
I believe the key error is this:

names’ attribute [84] must be the same length as the vector [82]

This is similar to this post here, which had set --p-n-threads to 0 for automatic detection over a cluster which had led to some incorrect thread calculations. Manually setting this value to the desired number of cores to use should solve the problem. Could you give that a try and let us know how that goes.
Good luck!

1 Like

The problem was solved after I had set a value for "–p-n-threads’’.

1 Like