DADA2 command does not running

Hello,

I am trying to run DADA2 using the below command, I have already run the previous step to get the demux-paired-end.qza, unfortunately I am stucked at the DADA2 and can not proceed, the system does not give me any error when I copy-paste the command, the curser blinks for few seconds and then stops... I waited for 10 hours because in my previous analysis (more than a year ago) this step took 9 hours on my mac. I uninstalled/installed Virtual box and qiime2 several times, freed space, etc... but nothing works..Please let me know if there is any solution to proceed. Thank you.

qiime dada2 denoise-paired
--i-demultiplexed-seqs demux-paired-end.qza
--p-trim-left-f 20
--p-trim-left-r 10
--p-trunc-len-f 280
--p-trunc-len-r 240
--o-table T1-table.qza
--o-representative-sequences T1-rep-seqs.qza
--o-denoising-stats T1-denoising-stats.qza

Updates,

I got this error after more than 12 hours, do you have any suggestion? Thank you in advance.

Plugin error from dada2:

An error was encountered while running DADA2 in R (return code -9), please inspect stdout and stderr to learn more.

Debug info has been saved to /tmp/qiime2-q2cli-err-xo8m9xhw.log

@salma_M,
can you save that log output and upload it so we can see it? You can use this command: cat /tmp/qiime2-q2cli-err-xo8m9xhw.log > ~/Desktop/dada2_error_log to save it to your desktop, and subsequently upload it.

You could also try running the command again with the --verbose flag set. But that might be a secondary step at this point. How big is your data? This is one of those operations that is dependent on the input dataset size, so sometimes it will just take a long time, which is not good if it is erroring out at the end :grimacing:.

Thnx for the reply. I have 66 samples (the initial fastq files folder was 6 GB).

I got this error when I tried to save the log output;
cat: /tmp/qiime2-q2cli-err-xo8m9xhw.log: No such file or directory

and I tried the --verbose and got this error; (1/1) Invalid value for '--i-demultiplexed-seqs': 'paired-end-demux.qza' is

not a valid filepath

Running external command line application(s). This may print messages to stdout and/or stderr.

The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_paired.R /tmp/tmpayq24wdu/forward /tmp/tmpayq24wdu/reverse /tmp/tmpayq24wdu/output.tsv.biom /tmp/tmpayq24wdu/track.tsv /tmp/tmpayq24wdu/filt_f /tmp/tmpayq24wdu/filt_r 280 240 20 10 2.0 2.0 2 12 independent consensus 1.0 1 1000000

R version 4.1.3 (2022-03-10)

Loading required package: Rcpp

DADA2: 1.22.0 / Rcpp: 1.0.8.3 / RcppParallel: 5.1.5

  1. Filtering ..................................................................

  2. Learning Error Rates

413002720 total bases in 1588472 reads from 7 samples will be used for learning the error rates.

@salma_M, can you run qiime info, conda list, and ls in the directory you are trying to run your commands + with your correct conda environment activated? It looks like it is having trouble finding your demultiplexed sequences and is spending a lot of time looking for them. Hopefully by letting QIIME 2 know exactly where they are we can get this working for you :slightly_smiling_face: