DADA2 Biostrings error

I am getting a Biostrings corrupt error while running DADA2. I have a conda install for 2021.11 version of qiime2. I have tried to run the same in a conda install of qiime2 2021.04 version with the same error. Attaching the log below. Can you help me with this error please?

Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_paired.R /tmp/tmp5zqe0qaj/forward /tmp/tmp5zqe0qaj/reverse /tmp/tmp5zqe0qaj/output.tsv.biom /tmp/tmp5zqe0qaj/track.tsv /tmp/tmp5zqe0qaj/filt_f /tmp/tmp5zqe0qaj/filt_r 270 220 0 0 2.0 2.0 2 12 independent consensus 1.0 1 1000000

R version 4.0.5 (2021-03-31)
Loading required package: Rcpp
Error: package or namespace load failed for ‘dada2’ in (function (n) :
lazy-load database '/home/arghyam/anaconda3/envs/qiime2/lib/R/library/Biostrings/R/Biostrings.rdb' is corrupt
Execution halted
Traceback (most recent call last):
File "/home/arghyam/anaconda3/envs/qiime2/lib/python3.8/site-packages/q2_dada2/", line 266, in denoise_paired
File "/home/arghyam/anaconda3/envs/qiime2/lib/python3.8/site-packages/q2_dada2/", line 36, in run_commands, check=True)
File "/home/arghyam/anaconda3/envs/qiime2/lib/python3.8/", line 516, in run
raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['run_dada_paired.R', '/tmp/tmp5zqe0qaj/forward', '/tmp/tmp5zqe0qaj/reverse', '/tmp/tmp5zqe0qaj/output.tsv.biom', '/tmp/tmp5zqe0qaj/track.tsv', '/tmp/tmp5zqe0qaj/filt_f', '/tmp/tmp5zqe0qaj/filt_r', '270', '220', '0', '0', '2.0', '2.0', '2', '12', 'independent', 'consensus', '1.0', '1', '1000000']' returned non-zero exit status 1.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/home/arghyam/anaconda3/envs/qiime2/lib/python3.8/site-packages/q2cli/", line 339, in call
results = action(**arguments)
File "", line 2, in denoise_paired
File "/home/arghyam/anaconda3/envs/qiime2/lib/python3.8/site-packages/qiime2/sdk/", line 245, in bound_callable
outputs = self.callable_executor(scope, callable_args,
File "/home/arghyam/anaconda3/envs/qiime2/lib/python3.8/site-packages/qiime2/sdk/", line 391, in callable_executor
output_views = self._callable(**view_args)
File "/home/arghyam/anaconda3/envs/qiime2/lib/python3.8/site-packages/q2_dada2/", line 279, in denoise_paired
raise Exception("An error was encountered while running DADA2"
Exception: An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

Hi @arghya1611,

Welcome to the :qiime2: forum!

It looks like some database within your instance of R is corrupt. Can you try restarting R and see if that resolves the issue?

Cheers :lizard:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.