Core Dumped During Visualizations

I’ve found that a couple of the visualization steps result in core dumped error and I haven’t been able to find any kind of fix elsewhere. Here are two examples of the errors:

7588 Aborted (core dumped) qiime demux summarize --i-data reads.qza --o-visualization reads.qzv

8820 Aborted (core dumped) qiime feature-table summarize --i-table repSeqsTable.qza --o-visualization repSeqsTable.qzv --m-sample-metadata-file $meta

I haven’t had a problem with any of the other visualization steps yet so they might be fine. We’re running this on a machine running Biolinux (built on Ubuntu 14.04) with 128 Gb of RAM. I installed a qiime2-2017.4 environment with Anaconda.

Thank you very much,

Hi @Shawn_Rupp! Sorry to hear you’re having troubles. By any chance are you running this on a headless server? If so, this looks like the kind of thing that matplotlib will complain about if it doesn’t have a display configured to use (for example, SSH without X forwarding). You can configure matplotlib to use an offscreen backend, see this forum post for an example. Hope that helps!


Thanks for the reply!

I was running this on a headless server, but I had the same problem on my desktop which is running Ubuntu 16.04. I was running into the error when I tried to generate the visualization (I ran a batch script to run through all of the steps and was going to examine the visualizations locally).

I configured matplotlib with:

echo "backend: Agg" > ~/.config/matplotlib/matplotlibrc

as you suggested and that seems to have solved the problem. Thanks for the help!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.