Can't install ANCOM package in R


(Jacqueline B) #1

About to toss computer out the window :computer:

I’ve been trying for about… 3 hours now… to load any and all ANCOM packages I can find in R.

I’m trying to use ANCOM 2.0 and I have installed exactRanksTest and nlme - no problems there.

I am currently running R version 3.5.2 (MacOS Mojave) but I have also attempted with version 3.3.3 and I have received a variety of error messages.

When I attempt to install the .tar.gz file directly from my computer I receive:
Warning in install.packages :
installation of package ‘/Users//Downloads/ancom_version_112/ancom.R_1.1-2.tar.gz’ had non-zero exit status

If I try:
install.packages("~/AncomR/ancom.R_1.1-2.tar.gz")

I receive:
Warning in install.packages :
package ‘~/AncomR/ancom.R_1.1-2.tar.gz’ is not available (for R version 3.5.2)


(Matthew Ryan Dillon) #2

Hi there @turtleonaleash - have you tried reaching out to the ANCOM 2 devs? I am not sure that any of them are on this forum…


(Jacqueline B) #3

Nope… I shall try that though! Thanks (again.)