Can't import MIDORI database to qiime

I'm trying to assign taxonomy to my 18S fungal sequences, and I've tried the pre-built qiime classifier for SILVA with no success. I wanted to download this database from MIDORI: Download/GenBank256_2023-06-21/QIIME/uniq/MIDORI2_UNIQ_NUC_GB256_srRNA_QIIME.fasta.gz

From their website: Download

because it's already preformatted for qiime. I unzipped the file and tried importing it into qiime using these commands, and got the following error.

gzip -d MIDORI2_UNIQ_NUC_GB256_srRNA_QIIME.fasta.gz

qiime tools import --input-path MIDORI2_UNIQ_NUC_GB256_srRNA_QIIME.fasta --output-pat
h MIDORI_UNIQUE-18S.seq.qza --type ‘FeatureData[Sequence]’

Error: Detected invalid character in: ‘FeatureData[Sequence]’
Verify the correct quotes or dashes (ASCII) are being used.

Has anyone encountered this error before? I can't see anything weird in the file other than some sequence headers having extra '<' or '>' symbols. Thanks for any help!

1 Like

Hello VSharp,

This is one of those strange computer issues: Those are "smart quotes" and they confuse the terminal

Try replacing those with normal quotes like 'these' or "these" and report back!

1 Like

Hi Colin,

You were right! I never would have noticed those quotes, thank you so much!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.