Cannot upload files (metadata and manifest) to qiime

Hi everyone! I'm very new to Qiime and having difficulty uploading everything into Qiime.

I'm running Qiime through ComputeCanada, where I have successfully built Qiime2 image through Singularity (more information could be found here QIIME - CC Doc). However, whenever I tried to upload files into Qiime, either metadata file or manifest file, Qiime told me that my files cannot be found.

Here is my code:

singularity exec qiime2-2021.11.sif qiime metadata tabulate
--m-input-file /home/siyu/scratch/miseq_2/metadatatsv.tsv
--o-visualization metadata.qzv

Here is my error:

There was an issue with loading the file /home/siyu/scratch/miseq_2/metadatatsv.tsv as metadata:

Metadata file path doesn't exist, or the path points to something other than a file. Please check that the path exists, has read permissions, and points to a regular file (not a directory): /home/siyu/scratch/miseq_2/metadatatsv.tsv

There may be more errors present in the metadata file. To get a full report, sample/feature metadata files can be validated with Keemei:

Find details on QIIME 2 metadata requirements here: Metadata in QIIME 2 — QIIME 2 2021.11.0 documentation

However, the file does exist by checking using ls command, and the file has been approved by Keemei.
[siy[email protected] miseq_2]$ ls /home/siyu/scratch/miseq_2/metadatatsv.tsv


Similarly, it also happened when I upload my manifest file.
Here is my code:
singularity exec qiime2-2021.11.sif qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path ~/scratch/manifest
--input-format PairedEndFastqManifestPhred33V2
--output-path paired-end-demux.qza

Here is the error:
There was a problem with the command:
(1/1) Invalid value for '--input-path': Path '/home/siyu/scratch/manifest'
does not exist.

However, the file does exist by checking with ls command
[[email protected] miseq_2]$ ls /home/siyu/scratch/manifest


And here is my manifest file:
manifest.tsv (18.2 KB)

I'll appreciate any comment or suggestion! Thank you so much!!

Hi @Siyu_Song,
I am not sure what is happening with your metadatatsv.tsv. Typically this is because 1) the file isn't exactly where you think it is or 2) there is a small spelling error. So I would make sure that the file is in /home/siyu/scratch/miseq_2/ and that everything is spelled correctly. When I run into this issue I use tab autocomplete to make sure that everything is spelled correctly.

As for your manifest file:

The issue is that the file is called manifest.tsv and not manifest

Hope this helps!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.