Can not find the correct files of SILVA 138 release

Hi,

I want to train my classifier using the new SILVA 138 release. I checked SILVA database, but the available formats are different from those of the previous releases. In other word, in 128, and 132, I downloaded a package of files from which I use silva_132_97_16S.fna by converting to qza, then consensus_taxonomy_7_levels.txt to generate a reference taxonomy.
I have attached the link of the new SILVA release and need to know which files should I download to train the classifier.

Thanks in advance
Eman

Hi @Eman,

Everything you need is on the Data Resources page, which was updated to reflect the 2020.6 release.

Specifically, the pre-made SILVA 138 classifiers are here, and the files used to make them are here. If you’d like a little more control preparing a SILVA database in your own way, feel free to make use of our new tool: RESCRIPt. This was used to make the current QIIME 2 compatible SILVA 138 release.

-Best wishes!
-Mike

3 Likes

Thank you! I checked Data resource page, but I felt uncomfortable when reading the warning message. I will try the new tool and keep the forum updated.
Thanks again
Eman

1 Like

No problem @Eman,

The quickest way to get started is to simply run the train classifier step yourself using the input files we provide.

Note, the security warning only applies to the classifiers, not these other files.

Otherwise, enjoy using RESCRIPt! :slight_smile:

-Mike

Yep - and also worth noting, @Eman - the warning will still apply to the classifiers that you yourself might train.

1 Like

Hello,

I am following the steps posted in the hyperlinked RESCRIPT and I have a first-step issue:

qiime rescript get-silva-data \
     --p-version '138' \
     --p-target 'SSURef_NR99' \
     --p-include-species-labels \
     --o-silva-sequences silva-138-ssu-nr99-seqs.qza \
     --o-silva-taxonomy silva-138-ssu-nr99-tax.qza

Error: QIIME 2 has no plugin/command named ‘rescript’.

Is there a step that I am missing?

Best
Eman

Hi @Eman,

RESCRIPt an external plugin that you need to install. The very first link in the tutorial links you to the github page with the instructions. All you need to do is activate your qiime environment and skip right to the pip install command step, and go from there.

-Mike

Hello,
OKay, I already installed rescript, then I ran the same code and got this error:

Plugin error from rescript:

Parameter ‘version’ received 138 as an argument, which is incompatible with parameter type: Str % Choices(‘128’, ‘132’)¹ | Str % Choices(‘138’)²

Debug info has been saved to /tmp/qiime2-q2cli-err-vsqfxas4.log

Is not it specific for 138 release? so, why this incompatibility issue?

Hi @Eman,

I’ve copied and pasted the command you posted earlier into my terminal and it worked without issue. Did you run the command any differently from what you initially posted?

This implies you are using combinations of --p-version and --p-target that are not allowed. That is you can only run

  • 128 or 132 with
    • ‘SSURef_NR99’
    • ‘SSURef’
    • ‘LSURef’
  • 138 with
    • ‘SSURef_NR99’
    • ‘SSURef’

Hope this helps!
Mike

1 Like

Good to know! So, that means no worries and it is recommended to use the posted files. Actually, I am just curious to try the updates in Qiime2 and SILVA.
Thanks so much

1 Like

Hello,
I am using the same command:

qiime rescript get-silva-data \
     --p-version '138' \
     --p-target 'SSURef_NR99' \
     --p-include-species-labels \
     --o-silva-sequences silva-138-ssu-nr99-seqs.qza \
     --o-silva-taxonomy silva-138-ssu-nr99-tax.qza

parameter version 138 with SSURef_NR99, I do not know where is the problem?
Sorry for asking so many questions.

1 Like

Not a problem @Eman,

I am wondering if there is something wrong with the install? One last test you can try is to not set the parameters, and use the defaults (with and without the --p-include-species-labels option). That is, if you run the following:

qiime rescript get-silva-data \
     --o-silva-sequences silva-seqs.qza \
     --o-silva-taxonomy silva-tax.qza

It will download and parse the SILVA 138 NR 99 files (w/o species labels), as these are set by default. This will ensure the problem is not coming from some odd hidden characters that are being entered in on the command line (that is, try typing the commands rather than pasting them). That’s all I can think of at the moment. :man_shrugging:

-Best wishes!
-Mike

qiime rescript get-silva-data \

 --o-silva-sequences silva-seqs.qza \
 --o-silva-taxonomy silva-tax.qza

Plugin error from rescript:

Parameter ‘version’ received 138 as an argument, which is incompatible with parameter type: Str % Choices(‘128’, ‘132’)¹ | Str % Choices(‘138’)²

Debug info has been saved to /tmp/qiime2-q2cli-err-d145rkqt.log

I don’t know how to fix it!
However, I tested the easiest way, and downloaded files and run
qiime feature-classifier fit-classifier-naive-bayes \

--i-reference-reads silva-138-99-seqs-515-806.qza \
--i-reference-taxonomy silva-138-99-tax-515-806.qza \
--o-classifier silva-138-99-515-806-classifier.qza

Now, I have my classifier, but I am interested in using rescript plugin :grinning:

Thanks
Eman

Hello,

One more thing that I forgot to mention, I created an environment within qiime environment to install rescript and other plugins (as in the noted website). That means every time I use these plugins, I have to activate both qiime, then rescript environment. Is that correct?

Thanks
Eman

Hi @Eman,

No need to have it set up that way. As I mentioned earlier:

This is also mentioned this on the github page:

First create a conda environment and install relevant dependencies (you can skip this step and install RESCRIPt in a conda environment containing QIIME 2 2020.2+, which should contain the necessary dependencies/versions)

That is, once you install QIIME 2 as outlined here, do the following:

conda activate qiime2-2020.2 # or later version, 2020.6
pip install git+https://github.com/bokulich-lab/RESCRIPt.git
qiime dev refresh-cache
qiime rescript --help

-Does this make sense?
-Mike

Thanks so much! That works great.
Best regards
Eman

1 Like