Black screen while running taxonomy analysis

Greetings to all. I am running qiime2 to analyse my 16s rDNA samples with a 200gb memory 8gb ram laptop. All steps were done with the aids of tutorials but I had encountered troubles when it comes to taxonomy analysis. My laptop went to a black screen after I ran the following command in my virtual box command line.

qiime feature-classifier classify-sklearn
--i-classifier gg-13-8-99-515-806-nb-classifier.qza
--i-reads rep-seqs.qza
--o-classification taxonomy.qza

Previously I suffered from memory error, I thought I fixed it but this is what I got now after I waited for 12 hours.

I appreciate your effort and time :bowing_woman::bowing_woman::bowing_woman::bowing_woman:
Sorry i had no further information since I posted this using my smart phone.
Thanks in advance.

1 Like

Does it still make sounds like it is working or is it silent?

Once my laptop got in sleep mode in the middle of an analysis and I couldn’t wake it up, then I turned off sleep mode. Maybe you could check that up.

I don’t know if this is a common error, I’m just running wild guesses here :slight_smile:

3 Likes

Hi. I knew the analysis will take time so I turn off sleep mode and make sure my laptop is always on. I am not sure what is going on now with it though. 24 hours passed and it is still black screen with only a mouse pointer on the screen. :joy:

1 Like

Maybe something failed, but maybe you can try to plug it into another monitor or perhaps it’s hanging because it ran out of memory - it may be worth just reattempting this run again. Ben

1 Like

How many samples are you analysing? I think size of the data is important at ram usage. 8 gb ram doesn’t look sufficient enough for me, yet I don’t know exactly how it is calculated. I remember my laptop using 16 gb ram + 5 gb swap space at this step of an analysis I did.

Still, I would go with @ben’s suggestion, but I believe it will run out of memory.

1 Like

To be honest this is the forth time my laptop turn black when I running this command. The first 3 times I was shocked so I forced restart my laptop… 8gb ram is not enough to run?

1 Like

That’s a good question, but I think it depends on how much data you’re putting through, but I think that I would favor that you have 16 gigs, but that’s just me.

My other thought is that your laptop is going to sleep, so you can try to turn off your power settings (but set them back when you’re done). Or you can try this trick if you’re running Mac with command line: https://computers.tutsplus.com/tutorials/quick-tip-how-to-stop-your-mac-from-sleeping-using-the-command-line--mac-50905

Ben

1 Like

I agree with @ben, although I think the machine going to sleep isn’t the host computer itself, but rather the virtual machine. The Virtualbox docs can be found here:

https://www.virtualbox.org/wiki/Downloads#manual

I also think this is probably too low, but, might not be related to the current issue.

1 Like