Best link for unconventional install of qiime2, simple issues with python and readonly file systems

I’m trying to install qiime2 largely to test my experimental code and compare it against validated approaches and from the questions I’ve seen on the forum think there may be people with intersting data if they will eventually share their problematic sequences. Due to my current eh umm architecture it is probably best to avoid build
systems and quickly move large files to a windows partition that is read only during actual execution.
I have no real familarity or interest in python but did get my c++ code to run from python 2.7 using boost python( it entered my console mode but the readline tab complete did not appear to work right otherwise ok). Despite their concerns about using bjam I was able to make the thing work by just compiling each cpp file and linking to the mass of object files :slight_smile:

So I thought I would take another shot at installing qiime2. My constraint is disk space on my Ubuntu partition so I’m moving all the read only stuff to a windohs partition.
Ideally I could just wget everything from cygwin and then use it by booting Ubuntu.
Avoding conda would seem to help.
In any case, I got qiime2 and tried to run it encountering this result for which there is probably a simple reason but was not sure immediately what the deal is and thought it would be easier to ask if others are dealing with similar issues. Thanks.

Python 2.7.2+ (default, Jul 20 2012, 22:15:08)
[GCC 4.6.1] on linux2
Type “help”, “copyright”, “credits” or “license” for more information.

import qiime2
Traceback (most recent call last):
File “”, line 1, in
File “qiime2/init.py”, line 9, in
from qiime2.sdk import Artifact, Visualization
File “qiime2/sdk/init.py”, line 9, in
from .context import Context
File “qiime2/sdk/context.py”, line 17
def get_action(self, plugin: str, action: str):
^
SyntaxError: invalid syntax

Update. I tried to install on my flash drive but it is vfat for 'dohs compatibility and would not install the symlinks. There was no obvious easy way to put the ( tiny )
links on ext4 pointing to vfat. Right now I’m trying to install using a spare machine
and NFS over the wifi ( I have a local cable but too lazy to bother now lol).
All the conda stuff is loading now, hopefully this is all transparent except for the
50Mbps wifi lol. There is 30Gb there but it would not install on that machine as likely OS
is too old complaining not 64 bit.

Miniconda itself claims to be about 400Mb lol.

Thanks.

It took several hours but the download was a small part of that it looks like it had
to process all the stuff. In any case the first part of the moving pictures demo does seem to run. Naturally with 6.5 Gb fone like that I was curious where it went,
I was going to copy/paste but find -type d is running very slow locally but dump from remote machine gives something like this as leading offenders. Hopefully I can eventually copy this to a local partition. Many people probably already have blast python and blas etc. Curious now to see how hard it is now to make a plugin.

85583869 ./pkgs/cache
120517995 ./envs/qiime2-2018-4/lib/python3.5/site-packages/scipy
120518068 ./pkgs/scipy-0.19.1-py35_blas_openblas_202/lib/python3.5/site-packages/scipy
120526260 ./pkgs/scipy-0.19.1-py35_blas_openblas_202/lib/python3.5/site-packages
120530356 ./pkgs/scipy-0.19.1-py35_blas_openblas_202/lib/python3.5
120534452 ./pkgs/scipy-0.19.1-py35_blas_openblas_202/lib
121049309 ./pkgs/scipy-0.19.1-py35_blas_openblas_202
365689209 ./envs/qiime2-2018-4/lib/python3.5/site-packages
370579861 ./envs/qiime2-2018-4/lib/python3.5
536864178 ./envs/qiime2-2018-4/lib
818459186 ./pkgs/blast-2.6.0-boost1.64_2/bin
818577053 ./pkgs/blast-2.6.0-boost1.64_2
833330304 ./envs/qiime2-2018-4/bin
1407011494 ./envs/qiime2-2018-4
1407015590 ./envs
2594198909 ./pkgs
6463956579 .

Hey there @marchywka! It looks like you solved your own question here. I a going to close this topic - if you have any more questions please post a new topic! Thanks! :t_rex: :qiime2: