Bash: --output-path: command not found

I was trying to run the “Moving Pictures” tutorial on VirtualBox. After the downloading steps, I tried to get the .qza file following the tutorial using:
qiime tools import
–type EMPSingleEndSequences
–input-path emp-single-end-sequences
–output-path emp-single-end-sequences.qza
However, it falied and I get the error message:
bash: qiime: command not found
Then I retried the “–output-path emp-single-end-sequences.qza” command, and I get another error message:
bash: --output-path: command not found
How would I fix this?

Welcome to the forum, @MAJAIN!

Please confirm your virtualbox image has successfully installed qiime 2. You can do this by opening the Virtualbox, opening a terminal window, and entering
qiime info
Please paste your results here. (There are good directions for setting up copy-paste in this tutorial) The ‘preformatted text’ option in the menu bar will help keep your post readable.

NOTE also: --output-path ... is an argument to qiime tools import, not an command per se, and cannot be used independently of qiime tools import and its other required arguments. Careful attention to punctuation (e.g. --, not - at the beginning of arguments, and backslashes to break long commands across multiple lines) might also help you get you on the right track.

Happy qiime-ing!

Hi @ ChrisKeefe!
Thanks for your reply, and it really helps! I tried “qiime info” as you mentioned, and finally figured out that the error occured because I was trying to solve the data through root access:sweat_smile: Everything works properly now, thanks for your advice.



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.