AttributeError: module ‘natsort’ has no attribute ‘compat’

Hi all,

I searched for the topic and it seems it hasn’t been addressed yet (if yes, sorry).

I am using QIIME2-2021.2 in conda on my terminal of Mac OS Big Sur 11.2.3 (8Gb of RAM and i5) and downloaded Silva 138 99% OTUs from 515F/806R region of sequences as a classifier.

When I run in my terminal:
qiime feature-classifier classify-sklearn --i-reads feature-data-sequence.qza --i-classifier silva-138-99-seqs-515-806.qza --o-classification taxonomy.qza , I obtain this error:
There was a problem loading silva-138-99-515-806-nb-classifier.qza as a QIIME 2 Result:
module ‘natsort’ has no attribute 'compat’
See above for debug info.

I already verified the version of scikit-learn, it is updated to 0.23.1. The working directory is also well set.

Could you please help me understand the error?

Many thanks!

The debug info are:
Traceback (most recent call last):
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/q2cli/click/”, line 112, in _convert_input
result = qiime2.sdk.Result.load(value)
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/”, line 66, in load
archiver = archive.Archiver.load(filepath)
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/core/archive/”, line 307, in load
return cls(path, Format(rec))
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/core/archive/format/”, line 29, in init
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/core/archive/format/”, line 73, in init
self.format = sdk.parse_format(format)
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/”, line 88, in parse_format
pm = qiime2.sdk.PluginManager()
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/”, line 54, in new
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/qiime2/sdk/”, line 81, in _init
plugin = entry_point.load()
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/pkg_resources/”, line 2472, in load
return self.resolve()
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/pkg_resources/”, line 2478, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_diversity/”, line 11, in
from ._beta import (beta, beta_phylogenetic, bioenv,
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_diversity/_beta/”, line 12, in
from ._visualizer import bioenv, beta_group_significance, mantel, adonis
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/q2_diversity/_beta/”, line 25, in
from natsort import natsorted
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/natsort/”, line 3, in
from natsort.natsort import (
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/natsort/”, line 201, in
natsort_key = natsort_keygen()
File “/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib/python3.6/site-packages/natsort/”, line 172, in natsort_keygen
sep = natsort.compat.locale.null_string
AttributeError: module ‘natsort’ has no attribute ‘compat’

Hi, @ElifKardas,

It sounds like your conda environment may be corrupt. Have you modified the environment in anyway after you originally created it? I would suggest removing the environment (conda env remove -n qiime2-2021.2) and repeating the native installation steps for mac os.

Hello @andrewsanchez ,

Thanks for your reply. I tried to remove it and reinstall it, but it doesn’t fix it… After installing the new env, it gave me this following error: Mac OS X: ValueError: unknown locale: UTF-8 in Python that I fixed with
export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

Do you think this fix that I found on Mac OS X: ValueError: unknown locale: UTF-8 in Python (Example) might be inducing my error of There was a problem loading silva-138-99-515-806-nb-classifier.qza as a QIIME 2 Result:
module ‘natsort’ has no attribute 'compat’
See above for debug info. ?


No, I don’t think these are related. Although it looks like natsort does all kinds of locale-related stuff, which does make me wonder…

Can you share:

  • the exact commands you used to
    • remove your old environment
    • recreate the new environment
  • the output of the following, after making sure your env is activated (conda activate qiime2-2021.2)
    • env | sort
    • conda list

After creating a qiime 2 env, did you run any other conda or pip commands?

Sure, I copy all this this here after, thanks for your time.

conda env remove -n qiime2-2021.2
wget conda env create -n qiime2-2021.2 --file qiime2-2021.2-py36-osx-conda.yml OPTIONAL CLEANUP rm qiime2-2021.2-py36-osx-conda.yml

env | sort
CFLAGS=-march=core2 -mtune=haswell -mssse3 -ftree-vectorize -fPIC -fPIE -fstack-protector-strong -O2 -pipe -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include
CMAKE_ARGS=-DCMAKE_AR=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-ar -DCMAKE_CXX_COMPILER_AR=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-ar -DCMAKE_C_COMPILER_AR=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-ar -DCMAKE_RANLIB=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-ranlib -DCMAKE_CXX_COMPILER_RANLIB=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-ranlib -DCMAKE_C_COMPILER_RANLIB=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-ranlib -DCMAKE_LINKER=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-ld -DCMAKE_STRIP=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-strip -DCMAKE_INSTALL_NAME_TOOL=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-install_name_tool -DCMAKE_LIBTOOL=/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/bin/x86_64-apple-darwin13.4.0-libtool -DCMAKE_OSX_DEPLOYMENT_TARGET= -DCMAKE_BUILD_TYPE=Release -DCMAKE_OSX_SYSROOT=/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk
CPPFLAGS=-D_FORTIFY_SOURCE=2 -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include
CXXFLAGS=-march=core2 -mtune=haswell -mssse3 -ftree-vectorize -fPIC -fPIE -fstack-protector-strong -O2 -pipe -stdlib=libc++ -fvisibility-inlines-hidden -std=c++14 -fmessage-length=0 -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include
DEBUG_CFLAGS=-march=core2 -mtune=haswell -mssse3 -ftree-vectorize -fPIC -fPIE -fstack-protector-strong -O2 -pipe -Og -g -Wall -Wextra -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include
DEBUG_CXXFLAGS=-march=core2 -mtune=haswell -mssse3 -ftree-vectorize -fPIC -fPIE -fstack-protector-strong -O2 -pipe -stdlib=libc++ -fvisibility-inlines-hidden -std=c++14 -fmessage-length=0 -Og -g -Wall -Wextra -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include
DEBUG_FFLAGS=-march=core2 -mtune=haswell -ftree-vectorize -fPIC -fstack-protector -O2 -pipe -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include -march=core2 -mtune=haswell -ftree-vectorize -fPIC -fstack-protector -O2 -pipe -Og -g -Wall -Wextra -fcheck=all -fbacktrace -fimplicit-none -fvar-tracking-assignments
DEBUG_FORTRANFLAGS=-march=core2 -mtune=haswell -ftree-vectorize -fPIC -fstack-protector -O2 -pipe -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include -march=core2 -mtune=haswell -ftree-vectorize -fPIC -fstack-protector -O2 -pipe -Og -g -Wall -Wextra -fcheck=all -fbacktrace -fimplicit-none -fvar-tracking-assignments
FFLAGS=-march=core2 -mtune=haswell -ftree-vectorize -fPIC -fstack-protector -O2 -pipe -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include
FORTRANFLAGS=-march=core2 -mtune=haswell -ftree-vectorize -fPIC -fstack-protector -O2 -pipe -isystem /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/include
LDFLAGS=-Wl,-pie -Wl,-headerpad_max_install_names -Wl,-dead_strip_dylibs -Wl,-rpath,/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib -L/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib
LDFLAGS_LD=-pie -headerpad_max_install_names -dead_strip_dylibs -rpath /Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib -L/Users/elifka/opt/miniconda3/envs/qiime2-2021.2/lib
MESON_ARGS=–buildtype release

conda list

packages in environment at /Users/elifka/opt/miniconda3/envs/qiime2-2021.2:

Name Version Build Channel

_r-mutex 1.0.1 anacondar_1 conda-forge
appnope 0.1.2 py36h79c6626_1 conda-forge
arb-bio-tools 6.0.6 h82bc0eb_8 bioconda
argon2-cffi 20.1.0 py36h20b66c6_2 conda-forge
async_generator 1.10 py_0 conda-forge
attrs 20.3.0 pyhd3deb0d_0 conda-forge
backcall 0.2.0 pyh9f0ad1d_0 conda-forge
backports 1.0 py_2 conda-forge
backports.functools_lru_cache 1.6.1 py_0 conda-forge
bibtexparser 1.1.0 py_0 conda-forge
bioconductor-biobase 2.50.0 r40h8909d69_0 bioconda
bioconductor-biocgenerics 0.36.0 r40_0 bioconda
bioconductor-biocparallel 1.24.0 r40h64ad5ed_0 bioconda
bioconductor-biostrings 2.58.0 r40h8909d69_0 bioconda
bioconductor-dada2 1.18.0 r40h64ad5ed_0 bioconda
bioconductor-delayedarray 0.16.0 r40h8909d69_0 bioconda
bioconductor-genomeinfodb 1.26.0 r40_0 bioconda
bioconductor-genomeinfodbdata 1.2.4 r40_0 bioconda
bioconductor-genomicalignments 1.26.0 r40h8909d69_0 bioconda
bioconductor-genomicranges 1.42.0 r40h8909d69_0 bioconda
bioconductor-iranges 2.24.0 r40h8909d69_0 bioconda
bioconductor-matrixgenerics 1.2.0 r40_0 bioconda
bioconductor-rhtslib 1.22.0 r40h8909d69_0 bioconda
bioconductor-rsamtools 2.6.0 r40h64ad5ed_0 bioconda
bioconductor-s4vectors 0.28.0 r40h8909d69_0 bioconda
bioconductor-shortread 1.48.0 r40h64ad5ed_0 bioconda
bioconductor-summarizedexperiment 1.20.0 r40_0 bioconda
bioconductor-xvector 0.30.0 r40h8909d69_0 bioconda
bioconductor-zlibbioc 1.36.0 r40h8909d69_0 bioconda
biom-format 2.1.10 py36hb29be1e_0 conda-forge
blas 2.108 openblas conda-forge
blas-devel 3.9.0 8_openblas conda-forge
blast 2.10.1 pl526hce2a5c9_3 bioconda
bleach 3.3.0 pyh44b312d_0 conda-forge
bokeh 2.2.3 py36h79c6626_0 conda-forge
boost-cpp 1.70.0 hef959ae_3 conda-forge
bowtie2 2.4.2 py36h0c56d2d_1 bioconda
brotlipy 0.7.0 py36h20b66c6_1001 conda-forge
bwidget 1.9.14 h694c41f_0 conda-forge
bzip2 1.0.8 hc929b4f_4 conda-forge
c-ares 1.17.1 h0d85af4_1 conda-forge
ca-certificates 2020.12.5 h033912b_0 conda-forge
cachecontrol 0.12.6 py_0 conda-forge
cached-property 1.5.1 py_0 conda-forge
cairo 1.16.0 he8db5a5_1006 conda-forge
cctools_osx-64 949.0.1 h2f0f38f_19 conda-forge
certifi 2020.12.5 py36h79c6626_1 conda-forge
cffi 1.14.5 py36hfaecaff_0 conda-forge
chardet 4.0.0 py36h79c6626_1 conda-forge
clang 11.0.1 h694c41f_1 conda-forge
clang-11 11.0.1 default_hf8bb9ca_1 conda-forge
clang_osx-64 11.0.1 hb91bd55_2 conda-forge
clangxx 11.0.1 default_hf8bb9ca_1 conda-forge
clangxx_osx-64 11.0.1 h7e1b574_2 conda-forge
click 7.1.2 pyh9f0ad1d_0 conda-forge
compiler-rt 11.0.1 h654b07c_0 conda-forge
compiler-rt_osx-64 11.0.1 h8c5fa43_0 conda-forge
cryptography 3.4.4 py36h0ecfcee_0 conda-forge
curl 7.71.1 hcb81553_8 conda-forge
cutadapt 3.2 py36he651532_0 bioconda
cycler 0.10.0 py_2 conda-forge
cython 0.29.22 py36hb100763_0 conda-forge
dataclasses 0.7 pyhe4b4509_6 conda-forge
deblur 1.1.0 py_2 bioconda
decorator 4.4.2 py_0 conda-forge
defusedxml 0.6.0 py_0 conda-forge
dendropy 4.5.2 pyh3252c3a_0 bioconda
dnaio 0.5.0 py36he651532_0 bioconda
emperor 1.0.1 py36h79c6626_1 conda-forge
entrez-direct 13.9 pl526h375a9b1_1 bioconda
entrypoints 0.3 pyhd8ed1ab_1003 conda-forge
expat 2.2.10 h1c7c35f_0 conda-forge
fastcluster 1.1.26 py36h72eec15_2 conda-forge
fasttree 2.1.10 0 bioconda
fontconfig 2.13.1 hd23ceaa_1004 conda-forge
freetype 2.10.4 h4cff582_1 conda-forge
fribidi 1.0.10 hbcb3906_0 conda-forge
future 0.18.2 py36h79c6626_3 conda-forge
gettext h7937167_1005 conda-forge
gfortran_impl_osx-64 9.3.0 h9cc0e5e_19 conda-forge
gfortran_osx-64 9.3.0 h18f7dce_14 conda-forge
glib 2.66.7 he49afe7_1 conda-forge
glib-tools 2.66.7 he49afe7_1 conda-forge
gmp 6.2.1 h2e338ed_0 conda-forge
gneiss 0.4.6 py_0 bioconda
graphite2 1.3.13 h2e338ed_1001 conda-forge
gsl 2.6 h71c5fe9_2 conda-forge
h5py 3.1.0 nompi_py36h9252a2b_100 conda-forge
harfbuzz 2.7.2 h73e2de6_1 conda-forge
hdf5 1.10.6 nompi_hc5d9132_1114 conda-forge
hdmedians 0.14.1 py36h809c706_1 conda-forge
hmmer 3.1b2 3 bioconda
htslib 1.11 h422799e_2 bioconda
icu 67.1 hb1e8313_0 conda-forge
idna 2.10 pyh9f0ad1d_0 conda-forge
ijson 3.1.3 pyhd3deb0d_0 conda-forge
importlib-metadata 3.4.0 py36h79c6626_0 conda-forge
importlib_metadata 3.4.0 hd8ed1ab_0 conda-forge
iniconfig 1.1.1 pyh9f0ad1d_0 conda-forge
ipykernel 5.5.0 py36h9cf137f_1 conda-forge
ipython 7.16.1 py36h9cf137f_2 conda-forge
ipython_genutils 0.2.0 py_1 conda-forge
ipywidgets 7.6.3 pyhd3deb0d_0 conda-forge
iqtree 2.0.3 h7eed37d_1 bioconda
isa-l 2.30.0 h0d85af4_4 conda-forge
isl 0.22.1 hb1e8313_2 conda-forge
jedi 0.17.2 py36h79c6626_1 conda-forge
jinja2 2.11.3 pyh44b312d_0 conda-forge
joblib 1.0.1 pyhd8ed1ab_0 conda-forge
jpeg 9d hbcb3906_0 conda-forge
jsonschema 3.2.0 pyhd8ed1ab_3 conda-forge
jupyter_client 6.1.11 pyhd8ed1ab_1 conda-forge
jupyter_core 4.7.1 py36h79c6626_0 conda-forge
jupyterlab_pygments 0.1.2 pyh9f0ad1d_0 conda-forge
jupyterlab_widgets 1.0.0 pyhd8ed1ab_1 conda-forge
kiwisolver 1.3.1 py36h615c93b_1 conda-forge
krb5 1.17.2 h60d9502_0 conda-forge
lcms2 2.12 h577c468_0 conda-forge
ld64_osx-64 530 hea264c1_19 conda-forge
ldid 2.1.2 h7660a38_2 conda-forge
libarbdb 6.0.6 h82bc0eb_8 bioconda
libblas 3.9.0 8_openblas conda-forge
libcblas 3.9.0 8_openblas conda-forge
libclang-cpp11 11.0.1 default_hf8bb9ca_1 conda-forge
libcurl 7.71.1 h9bf37e3_8 conda-forge
libcxx 11.0.1 habf9029_0 conda-forge
libdeflate 1.7 h35c211d_5 conda-forge
libedit 3.1.20191231 h0678c8f_2 conda-forge
libev 4.33 haf1e3a3_1 conda-forge
libffi 3.3 h046ec9c_2 conda-forge
libgcc 4.8.5 1 conda-forge
libgfortran 5.0.0 9_3_0_h6c81a4c_20 conda-forge
libgfortran-devel_osx-64 9.3.0 h6c81a4c_20 conda-forge
libgfortran5 9.3.0 h6c81a4c_20 conda-forge
libglib 2.66.7 hd556434_1 conda-forge
libiconv 1.16 haf1e3a3_0 conda-forge
liblapack 3.9.0 8_openblas conda-forge
liblapacke 3.9.0 8_openblas conda-forge
libllvm11 11.0.1 h223d4b2_0 conda-forge
libnghttp2 1.43.0 h07e645a_0 conda-forge
libopenblas 0.3.12 openmp_h54245bb_1 conda-forge
libpng 1.6.37 h7cec526_2 conda-forge
libsodium 1.0.18 hbcb3906_1 conda-forge
libssh2 1.9.0 h52ee1ee_6 conda-forge
libtiff 4.2.0 h355d032_0 conda-forge
libwebp-base 1.2.0 h0d85af4_2 conda-forge
libxml2 2.9.10 h2c6e4a5_2 conda-forge
llvm-openmp 11.0.1 h7c73e74_0 conda-forge
llvm-tools 11.0.1 h223d4b2_0 conda-forge
lockfile 0.12.2 py_1 conda-forge
lz4 3.1.3 py36h8314f8a_0 conda-forge
lz4-c 1.9.3 h046ec9c_0 conda-forge
mafft 7.475 h0b31af3_0 bioconda
make 4.3 h22f3db7_1 conda-forge
markupsafe 1.1.1 py36h20b66c6_3 conda-forge
matplotlib 3.2.2 1 conda-forge
matplotlib-base 3.2.2 py36h83d3ec1_1 conda-forge
mistune 0.8.4 py36h20b66c6_1003 conda-forge
more-itertools 8.7.0 pyhd8ed1ab_0 conda-forge
mpc 1.1.0 ha57cd0f_1009 conda-forge
mpfr 4.0.2 h72d8aaf_1 conda-forge
msgpack-python 1.0.2 py36h615c93b_1 conda-forge
natsort 7.1.1 pyhd8ed1ab_0 conda-forge
nbclient 0.5.2 pyhd8ed1ab_0 conda-forge
nbconvert 6.0.7 py36h79c6626_3 conda-forge
nbformat 5.1.2 pyhd8ed1ab_1 conda-forge
ncurses 6.2 h2e338ed_4 conda-forge
nest-asyncio 1.4.3 pyhd8ed1ab_0 conda-forge
networkx 2.5 py_0 conda-forge
nose 1.3.7 py_1006 conda-forge
notebook 6.2.0 py36h79c6626_0 conda-forge
numpy 1.19.5 py36h08dc641_1 conda-forge
olefile 0.46 pyh9f0ad1d_1 conda-forge
openblas 0.3.12 openmp_hd4b4ca2_1 conda-forge
openjdk 11.0.8 hb0a8c7a_0 conda-forge
openssl 1.1.1j hbcf498f_0 conda-forge
packaging 20.9 pyh44b312d_0 conda-forge
pandas 1.1.5 py36h2be6da3_0 conda-forge
pandoc 2.11.4 h35c211d_0 conda-forge
pandocfilters 1.4.2 py_1 conda-forge
pango 1.42.4 ha86e081_5 conda-forge
parso 0.7.1 pyh9f0ad1d_0 conda-forge
patsy 0.5.1 py_0 conda-forge
pcre 8.44 hb1e8313_0 conda-forge
pcre2 10.36 h5cf9962_1 conda-forge
perl 5.26.2 hbcb3906_1008 conda-forge
perl-archive-tar 2.32 pl526_0 bioconda
perl-base 2.23 pl526_1 bioconda
perl-business-isbn 3.004 pl526_0 bioconda
perl-business-isbn-data 20140910.003 pl526_0 bioconda
perl-carp 1.38 pl526_3 bioconda
perl-common-sense 3.74 pl526_2 bioconda
perl-compress-raw-bzip2 2.087 pl526h6de7cb9_0 bioconda
perl-compress-raw-zlib 2.087 pl526h770b8ee_0 bioconda
perl-constant 1.33 pl526_1 bioconda
perl-data-dumper 2.173 pl526_0 bioconda
perl-digest-hmac 1.03 pl526_3 bioconda
perl-digest-md5 2.55 pl526_0 bioconda
perl-encode 2.88 pl526_1 bioconda
perl-encode-locale 1.05 pl526_6 bioconda
perl-exporter 5.72 pl526_1 bioconda
perl-exporter-tiny 1.002001 pl526_0 bioconda
perl-extutils-makemaker 7.36 pl526_1 bioconda
perl-file-listing 6.04 pl526_1 bioconda
perl-html-parser 3.72 pl526h04f5b5a_5 bioconda
perl-html-tagset 3.20 pl526_3 bioconda
perl-html-tree 5.07 pl526_1 bioconda
perl-http-cookies 6.04 pl526_0 bioconda
perl-http-daemon 6.01 pl526_1 bioconda
perl-http-date 6.02 pl526_3 bioconda
perl-http-message 6.18 pl526_0 bioconda
perl-http-negotiate 6.01 pl526_3 bioconda
perl-io-compress 2.087 pl526h6de7cb9_0 bioconda
perl-io-html 1.001 pl526_2 bioconda
perl-io-socket-ssl 2.066 pl526_0 bioconda
perl-io-zlib 1.10 pl526_2 bioconda
perl-json 4.02 pl526_0 bioconda
perl-json-xs 2.34 pl526h04f5b5a_3 bioconda
perl-libwww-perl 6.39 pl526_0 bioconda
perl-list-moreutils 0.428 pl526_1 bioconda
perl-list-moreutils-xs 0.428 pl526_0 bioconda
perl-lwp-mediatypes 6.04 pl526_0 bioconda
perl-lwp-protocol-https 6.07 pl526_4 bioconda
perl-mime-base64 3.15 pl526_1 bioconda
perl-mozilla-ca 20180117 pl526_1 bioconda
perl-net-http 6.19 pl526_0 bioconda
perl-net-ssleay 1.88 pl526hb1dc21d_0 bioconda
perl-ntlm 1.09 pl526_4 bioconda
perl-parent 0.236 pl526_1 bioconda
perl-pathtools 3.75 pl526h1de35cc_1 bioconda
perl-scalar-list-utils 1.52 pl526h01d97ff_0 bioconda
perl-socket 2.027 pl526_1 bioconda
perl-storable 3.15 pl526h1de35cc_0 bioconda
perl-test-requiresinternet 0.05 pl526_0 bioconda
perl-time-local 1.28 pl526_1 bioconda
perl-try-tiny 0.30 pl526_1 bioconda
perl-types-serialiser 1.0 pl526_2 bioconda
perl-uri 1.76 pl526_0 bioconda
perl-www-robotrules 6.02 pl526_3 bioconda
perl-xml-namespacesupport 1.12 pl526_0 bioconda
perl-xml-parser 2.44_01 pl526hb1d6bea_1002 conda-forge
perl-xml-sax 0.99 pl526_1 bioconda
perl-xml-sax-base 1.09 pl526_0 bioconda
perl-xml-sax-expat 0.51 pl526_3 bioconda
perl-xml-simple 2.25 pl526_1 bioconda
perl-xsloader 0.24 pl526_0 bioconda
pexpect 4.8.0 pyh9f0ad1d_2 conda-forge
pickleshare 0.7.5 py_1003 conda-forge
pigz 2.5 haaf19a9_0 conda-forge
pillow 8.1.0 py36h0332b30_2 conda-forge
pip 21.0.1 pyhd8ed1ab_0 conda-forge
pixman 0.40.0 hbcb3906_0 conda-forge
pluggy 0.13.1 py36h79c6626_4 conda-forge
prometheus_client 0.9.0 pyhd3deb0d_0 conda-forge
prompt-toolkit 3.0.16 pyha770c72_0 conda-forge
psutil 5.8.0 py36h20b66c6_1 conda-forge
ptyprocess 0.7.0 pyhd3deb0d_0 conda-forge
py 1.10.0 pyhd3deb0d_0 conda-forge
pycparser 2.20 pyh9f0ad1d_2 conda-forge
pygments 2.8.0 pyhd8ed1ab_0 conda-forge
pyopenssl 20.0.1 pyhd8ed1ab_0 conda-forge
pyparsing 2.4.7 pyh9f0ad1d_0 conda-forge
pyrsistent 0.17.3 py36h20b66c6_2 conda-forge
pysocks 1.7.1 py36h79c6626_3 conda-forge
pytest 6.2.2 py36h79c6626_0 conda-forge
python 3.6.13 h7728216_0_cpython conda-forge
python-dateutil 2.8.1 py_0 conda-forge
python-isal 0.5.0 py36h49ba835_0 conda-forge
python_abi 3.6 1_cp36m conda-forge
pytz 2021.1 pyhd8ed1ab_0 conda-forge
pyyaml 5.4.1 py36h20b66c6_0 conda-forge
pyzmq 22.0.3 py36h50cd92c_1 conda-forge
q2-alignment 2021.2.0 py36_0 qiime2/label/r2021.2
q2-composition 2021.2.0 py36_0 qiime2/label/r2021.2
q2-cutadapt 2021.2.0 py36_0 qiime2/label/r2021.2
q2-dada2 2021.2.0 py36_0 qiime2/label/r2021.2
q2-deblur 2021.2.0 py36_0 qiime2/label/r2021.2
q2-demux 2021.2.0 py36_0 qiime2/label/r2021.2
q2-diversity 2021.2.0 py36_0 qiime2/label/r2021.2
q2-diversity-lib 2021.2.0 0 qiime2/label/r2021.2
q2-emperor 2021.2.0 py36_0 qiime2/label/r2021.2
q2-feature-classifier 2021.2.0 py36_0 qiime2/label/r2021.2
q2-feature-table 2021.2.0 py36_0 qiime2/label/r2021.2
q2-fragment-insertion 2021.2.0 py36_0 qiime2/label/r2021.2
q2-gneiss 2021.2.0 py36_0 qiime2/label/r2021.2
q2-longitudinal 2021.2.0 py36_0 qiime2/label/r2021.2
q2-metadata 2021.2.0 py36_0 qiime2/label/r2021.2
q2-phylogeny 2021.2.0 py36_0 qiime2/label/r2021.2
q2-quality-control 2021.2.0 py36_0 qiime2/label/r2021.2
q2-quality-filter 2021.2.0 py36_0 qiime2/label/r2021.2
q2-sample-classifier 2021.2.0 py36_0 qiime2/label/r2021.2
q2-taxa 2021.2.0 py36_0 qiime2/label/r2021.2
q2-types 2021.2.0 py36_0 qiime2/label/r2021.2
q2-vsearch 2021.2.0 py36_0 qiime2/label/r2021.2
q2cli 2021.2.0 py36_0 qiime2/label/r2021.2
q2templates 2021.2.0 py36_0 qiime2/label/r2021.2
qiime2 2021.2.0 py36_0 qiime2/label/r2021.2
r-assertthat 0.2.1 r40h6115d3f_2 conda-forge
r-backports 1.2.1 r40h066c5db_0 conda-forge
r-base 4.0.3 hc5aadab_3 conda-forge
r-bh 1.75.0_0 r40hc72bb7e_0 conda-forge
r-bitops 1.0_6 r40h17f1fa6_1004 conda-forge
r-brio 1.1.1 r40h066c5db_0 conda-forge
r-callr 3.5.1 r40h142f84f_0 conda-forge
r-cli 2.3.1 r40hc72bb7e_0 conda-forge
r-cluster 2.1.1 r40h59bb11e_0 conda-forge
r-colorspace 2.0_0 r40h6b199c2_0 conda-forge
r-crayon 1.4.1 r40hc72bb7e_0 conda-forge
r-desc 1.2.0 r40h6115d3f_1003 conda-forge
r-diffobj 0.3.3 r40h066c5db_0 conda-forge
r-digest 0.6.27 r40h342fd00_0 conda-forge
r-ellipsis 0.3.1 r40h17f1fa6_0 conda-forge
r-evaluate 0.14 r40h6115d3f_2 conda-forge
r-fansi 0.4.2 r40h066c5db_0 conda-forge
r-farver 2.0.3 r40hc5da6b9_1 conda-forge
r-formatr 1.7 r40h6115d3f_2 conda-forge
r-futile.logger 1.4.3 r40h6115d3f_1003 conda-forge
r-futile.options 1.0.1 r40h6115d3f_1002 conda-forge
r-ggplot2 3.3.3 r40hc72bb7e_0 conda-forge
r-glue 1.4.2 r40h066c5db_0 conda-forge
r-gtable 0.3.0 r40h6115d3f_3 conda-forge
r-hwriter 1.3.2 r40h6115d3f_1003 conda-forge
r-isoband 0.2.3 r40h1019320_0 conda-forge
r-jpeg 0.1_8.1 r40h17f1fa6_1 conda-forge
r-jsonlite 1.7.2 r40h066c5db_0 conda-forge
r-labeling 0.4.2 r40h142f84f_0 conda-forge
r-lambda.r 1.2.4 r40h6115d3f_1 conda-forge
r-lattice 0.20_41 r40h066c5db_3 conda-forge
r-latticeextra 0.6_29 r40h6115d3f_1 conda-forge
r-lifecycle 1.0.0 r40hc72bb7e_0 conda-forge
r-magrittr 2.0.1 r40h066c5db_1 conda-forge
r-mass 7.3_53.1 r40hf6ff476_0 conda-forge
r-matrix 1.3_2 r40h9a4b173_0 conda-forge
r-matrixstats 0.58.0 r40hf6ff476_0 conda-forge
r-mgcv 1.8_34 r40h9a4b173_0 conda-forge
r-munsell 0.5.0 r40h6115d3f_1003 conda-forge
r-nlme 3.1_152 r40h59bb11e_0 conda-forge
r-permute 0.9_5 r40h6115d3f_3 conda-forge
r-pillar 1.5.0 r40hc72bb7e_0 conda-forge
r-pkgbuild 1.2.0 r40hc72bb7e_0 conda-forge
r-pkgconfig 2.0.3 r40h6115d3f_1 conda-forge
r-pkgload 1.2.0 r40h4efb63e_0 conda-forge
r-plyr 1.8.6 r40hc5da6b9_1 conda-forge
r-png 0.1_7 r40h17f1fa6_1004 conda-forge
r-praise 1.0.0 r40h6115d3f_1004 conda-forge
r-prettyunits 1.1.1 r40h6115d3f_1 conda-forge
r-processx 3.4.5 r40he27d7ee_0 conda-forge
r-ps 1.5.0 r40h066c5db_0 conda-forge
r-r6 2.5.0 r40hc72bb7e_0 conda-forge
r-rcolorbrewer 1.1_2 r40h6115d3f_1003 conda-forge
r-rcpp 1.0.6 r40h815b84a_0 conda-forge
r-rcppparallel 5.0.2 r40hc5da6b9_0 conda-forge
r-rcurl 1.98_1.2 r40h17f1fa6_1 conda-forge
r-rematch2 2.1.2 r40h6115d3f_1 conda-forge
r-reshape2 1.4.4 r40hc5da6b9_1 conda-forge
r-rlang 0.4.10 r40h066c5db_0 conda-forge
r-rprojroot 2.0.2 r40hc72bb7e_0 conda-forge
r-rstudioapi 0.13 r40hc72bb7e_0 conda-forge
r-scales 1.1.1 r40h6115d3f_0 conda-forge
r-snow 0.4_3 r40h6115d3f_1002 conda-forge
r-stringi 1.5.3 r40hdb83bab_0 conda-forge
r-stringr 1.4.0 r40h6115d3f_2 conda-forge
r-testthat 3.0.2 r40h4efb63e_0 conda-forge
r-tibble 3.0.6 r40hf6ff476_0 conda-forge
r-utf8 1.1.4 r40h17f1fa6_1003 conda-forge
r-vctrs 0.3.6 r40h066c5db_0 conda-forge
r-vegan 2.5_7 r40h0a2d2ed_0 conda-forge
r-viridislite 0.3.0 r40h6115d3f_1003 conda-forge
r-waldo 0.2.4 r40hc72bb7e_0 conda-forge
r-withr 2.4.1 r40hc72bb7e_0 conda-forge
r-zeallot 0.1.0 r40h6115d3f_1002 conda-forge
raxml 8.2.12 h0b31af3_2 bioconda
readline 8.0 h0678c8f_2 conda-forge
requests 2.25.1 pyhd3deb0d_0 conda-forge
samtools 1.11 h725deca_0 bioconda
scikit-bio 0.5.6 py36h642477c_4 conda-forge
scikit-learn 0.23.1 py36hef903b7_0 conda-forge
scipy 1.5.3 py36h04de62b_0 conda-forge
seaborn 0.11.1 hd8ed1ab_1 conda-forge
seaborn-base 0.11.1 pyhd8ed1ab_1 conda-forge
send2trash 1.5.0 py_0 conda-forge
sepp 4.3.10 py36heb1dbbb_2 bioconda
setuptools 49.6.0 py36h79c6626_3 conda-forge
sina 1.7.2 hadaa689_0 bioconda
six 1.15.0 pyh9f0ad1d_0 conda-forge
sortmerna 2.0 h5c9b4e4_4 bioconda
sqlite 3.34.0 h17101e1_0 conda-forge
statsmodels 0.12.2 py36hf14bfbd_0 conda-forge
tapi 1100.0.11 h9ce4665_0 conda-forge
tbb 2020.2 h940c156_4 conda-forge
terminado 0.9.2 py36h79c6626_0 conda-forge
testpath 0.4.4 py_0 conda-forge
threadpoolctl 2.1.0 pyh5ca1d4c_0 conda-forge
tk 8.6.10 h0419947_1 conda-forge
tktable 2.10 h49f0cf7_3 conda-forge
toml 0.10.2 pyhd8ed1ab_0 conda-forge
tornado 6.1 py36h20b66c6_1 conda-forge
traitlets 4.3.3 py36h9f0ad1d_1 conda-forge
typing_extensions py_0 conda-forge
tzlocal 2.1 pyh9f0ad1d_0 conda-forge
unifrac 0.20.2 py36h098b9da_0 bioconda
urllib3 1.26.3 pyhd8ed1ab_0 conda-forge
vsearch 2.7.0 1 bioconda
wcwidth 0.2.5 pyh9f0ad1d_2 conda-forge
webencodings 0.5.1 py_1 conda-forge
wheel 0.36.2 pyhd3deb0d_0 conda-forge
widgetsnbextension 3.5.1 py36h79c6626_4 conda-forge
xopen 1.1.0 py36h79c6626_1 conda-forge
xz 5.2.5 haf1e3a3_1 conda-forge
yaml 0.2.5 haf1e3a3_0 conda-forge
zeromq 4.3.4 h1c7c35f_0 conda-forge
zipp 3.4.0 py_0 conda-forge
zlib 1.2.11 h7795811_1010 conda-forge
zstd 1.4.8 hf387650_1 conda-forge

Yes after creating my qiime2-2021.2 env, I activate the env with conda activate qiime2-2021.2

Then I set my wd, and I run my analysis command:
qiime feature-classifier classify-sklearn --i-reads feature-data-sequence.qza --i-classifier silva-138-99-seqs-515-806-nb-classifier.qza --o-classification taxonomy.qza

Btw, it sometimes gives me a new error, the same as mentioned already in other topics such as :

Do you think all these bugs are related to a prob of memory ? I copy here the output of
df -ha

Filesystem Size Used Avail Capacity iused ifree %iused Mounted on
/dev/disk1s5s1 233Gi 14Gi 71Gi 17% 568975 2447532345 0% /
devfs 197Ki 197Ki 0Bi 100% 680 0 100% /dev
/dev/disk1s4 233Gi 2.0Gi 71Gi 3% 2 2448101318 0% /System/Volumes/VM
/dev/disk1s2 233Gi 413Mi 71Gi 1% 1408 2448099912 0% /System/Volumes/Preboot
/dev/disk1s6 233Gi 2.3Mi 71Gi 1% 16 2448101304 0% /System/Volumes/Update
/dev/disk1s1 233Gi 145Gi 71Gi 68% 1479296 2446622024 0% /System/Volumes/Data
map auto_home 0Bi 0Bi 0Bi 100% 0 0 100% /System/Volumes/Data/home
/dev/disk3s2 931Gi 167Gi 679Gi 20% 1041219 9764536221 0% /Volumes/LaCie
[email protected]/dev/disk3s2 931Gi 166Gi 679Gi 20% 1041180 9764536260 0% /Volumes/.timemachine/46759459-3004-4437-9B7E-60183154311A/2020-12-26-170816.backup
/dev/disk1s7 233Gi 832Ki 71Gi 1% 92 2448101228 0% /Volumes/macOS Beta
/dev/disk3s1 931Gi 85Gi 679Gi 12% 950253 9764627187 0% /Volumes/Sauvegardes de MacBook Pro de Elif
[email protected]/dev/disk1s7 233Gi 820Ki 71Gi 1% 92 2448101228 0% /Volumes/ Pro de Elif/2021-03-19-130444/macOS Beta
[email protected]/dev/disk1s1 233Gi 143Gi 71Gi 67% 1582340 2446518980 0% /Volumes/ Pro de Elif/2021-03-19-130444/Macintosh HD - Données

Are you still getting the error that you originally reported after a clean installation? AttributeError: module ‘natsort’ has no attribute ‘compat’

Do you mean to say that sometimes you get the AttributeError: module ‘natsort’ has no attribute ‘compat’ and sometimes you get the Invalid value error? If that is the case, do you observe that behavior when trying to run the exact same command with the same input files, etc?

@ElifKardas, In the meantime, I recommend a more aggressive way of cleaning up and re-installing the environment:

  • conda clean -a
  • conda remove -n qiime2-2021.2 --all
    • This will make sure that when you try to recreate the env, it will use brand new packages instead of your local cache.
  • Then create a new, native installation as you normally would
conda env create -n qiime2-2021.2 --file qiime2-2021.2-py36-osx-conda.yml
rm qiime2-2021.2-py36-osx-conda.yml

Thank you for your advices, unfortunately it still doesn’t work.

Yes, I observe this behavior when I run the exact same command with the same input files.

I did the aggressive cleaning and it still doesn’t work - I almost believed it though, it ran a long time before giving me the same error AttributeError: module ‘natsort’ has no attribute ‘compat’.

I’ll try on another computer today.

Hey @ElifKardas, I have a request to make, can you try again, but switching the order of the first two commands?

conda remove -n qiime2-2021.2 --all
conda clean -a
conda env create -n qiime2-2021.2 --file qiime2-2021.2-py36-osx-conda.yml
rm qiime2-2021.2-py36-osx-conda.yml

It looks to me like you have a corrupt conda package in your conda cache, and that is why you're seeing this "natsort" error - I have seen this kind of thing happen before - a small network hiccup can cause all kinds of issues.

The reason I propose swapping the first two commands is because in their original order they might not actually remove the offending package (sorry @andrewsanchez, I missed that earlier). The conda clean command won't remove any packages from the cache that are currently being used in an env, so that's why I suggest inverting the order, just to be sure. You might also want to run it more than once - in older versions of conda it would take multiple passes to remove.


1 Like

Thanks for your answers.

Unfortunately, it did not work, even by inverting the two lines. I still received the same AttributeError with natsort.
I decided to uninstall Miniconda completely and it appears to work. Well, I’m not sure though because the qiime2 command is still running. But at least it doesn’t give me the previous error. I think I don’t have enough RAM to do so (from previous discussions), so I’ll work in the cloud of my uni.

Thanks a lot to both of you for your time.


Interesting! Thanks for updating - I think this is still very strongly likely a corrupt package - I think by removing your miniconda installation you completely ensured that the offending package wasn't present. One reason the package might not have uninstalled in your earlier attempts to clean the cache out might be because another conda env was using the package - for example, maybe you had more than one QIIME 2 env? Anyway, I'm updating here to let future readers know that I am still convinced that this was a corrupt conda package, and to endorse your solution to reinstall miniconda - that was actually going to be my next suggestion, you beat me to it!

Keep us posted!



Hi @thermokarst and @andrewsanchez

Update: After removing and reinstalling my conda env, I did not get the same error, but the command just did not complete - I did not have sufficient RAM… BUT I am happy to announce that it worked in the cluster of my university (in 56 sec!) :star_struck: :partying_face:

Thanks y’all!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.