assigning taxonomy using SILVA

Hello! I am having trouble with some code using feature-classifier. Getting this error:
"(1/1?) --p-n-jobs option requires an argument"
I've included the whole output below, any help would be appreciated greatly! I'm still learning the basics of qiime2. :slight_smile:

(qiime2) [email protected]:~$ qiime feature-classifier classify-sklearn \

--i-reads $output/EW_ASV_table.qza
--i-classifier silva-138-99-515-806-nb-classifier.qza
--o-classification $output/EW_SILVA_138.qza
--p-n-jobs $threads
Usage: qiime feature-classifier classify-sklearn [OPTIONS]

Classify reads by taxon using a fitted classifier.

--i-reads ARTIFACT FeatureData[Sequence]
The feature data to be classified. [required]
--i-classifier ARTIFACT
TaxonomicClassifier The taxonomic classifier for classifying the reads.
--p-reads-per-batch INTEGER
Range(0, None) Number of reads to process in each batch. If "auto",
this parameter is autoscaled to min( number of query
sequences / n-jobs, 20000). [default: 0]
--p-n-jobs INTEGER The maximum number of concurrently worker processes.
If -1 all CPUs are used. If 1 is given, no parallel
computing code is used at all, which is useful for
debugging. For n-jobs below -1, (n_cpus + 1 + n-jobs)
are used. Thus for n-jobs = -2, all CPUs but one are
used. [default: 1]
--p-pre-dispatch TEXT "all" or expression, as in "3n_jobs". The number of
batches (of tasks) to be pre-dispatched.
[default: '2
--p-confidence VALUE Float % Range(0, 1, inclusive_end=True) | Str %
Choices('disable') Confidence threshold for limiting taxonomic depth.
Set to "disable" to disable confidence calculation,
or 0 to calculate confidence but not apply it to
limit the taxonomic depth of the assignments.
[default: 0.7]
--p-read-orientation TEXT Choices('same', 'reverse-complement', 'auto')
Direction of reads with respect to reference
sequences. same will cause reads to be classified
unchanged; reverse-complement will cause reads to be
reversed and complemented prior to classification.
"auto" will autodetect orientation based on the
confidence estimates for the first 100 reads.
[default: 'auto']
--o-classification ARTIFACT FeatureData[Taxonomy]
--output-dir PATH Output unspecified results to a directory
--verbose / --quiet Display verbose output to stdout and/or stderr
during execution of this action. Or silence output if
execution is successful (silence is golden).
--examples Show usage examples and exit.
--citations Show citations and exit.
--help Show this message and exit.

                There was a problem with the command:                     

(1/1?) --p-n-jobs option requires an argument

Hi @Lisou,

It appears that this error:

Is likely failing due to the $threads variable not being defined. Are you sure $threads is being defined properly? You can do this by typing echo $threads in the terminal. If you do not see a value returned, then you need to double check if the variable threads is being assigned. Otherwise, remove --p-n-jobs flag (defaults to 1), or set --p-n-jobs 2, etc... Note: using more than 3-4 threads can lead to large amounts of memory being used. Unless you have more than 64 GB of RAM, I'd avoid using more than 2 threads.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.