ANCOM Empty Metadata Column Error


I’m trying to apply differential abundance testing with ANCOM. However, I ran into an error when I ran the following:
qiime composition ancom \ --i-table $Q2P/comp-material-table.qza \ --m-metadata-file $Q2P/CC-trial1-metadata.tsv \ --m-metadata-column Material \ --o-visualization $Q2P/ancom-CC-Material.qzv

Plugin error from composition:

All IDs were filtered out of the MetadataColumn, resulting in an empty MetadataColumn object.

Debug info has been saved to /var/folders/zs/30xfcww916qb84m7xvd0pv240000gn/T/qiime2-q2cli-err-xmxcqkta.log

I’m not sure of how to interpret this error?


Hi @ninaxhua,

The error is telling you (in a roundabout way) that the IDs don’t match your table. More specifically the IDs of the column (from CC-trial1-metadata.tsv) are being restricted to the IDs in the table, but there weren’t any left after doing that, meaning none of them match.

Hope that helps!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.