Alpha rarefaction

Hello QIIME community,

I have encountered a problem while working through the QIIME tutorial with my data. I ran the alpha rarefaction script (copied below) and the visualization was successfully made. When I use the Qiime tool view function I'm brought to a page that shows nothing (I've attached a screen-shot). I've deleted and re-ran the script but it continues to show nothing. I know what it should look like, I worked through the "Moving Pictures" tutorial.
Any suggestions would be appreciated.
Thank you.

"qiime diversity alpha-rarefaction --i-table table.qza --i-phylogeny rooted-tree.qza --p-max-depth 59264 --m-metadata-file ~/Documents/data/CrowMicrobiota-metadata.tsv --o-visualization alpha-rarefaction.qzv"

Oh no! That certainly looks like a bug :bug:!! Would you be able to share that QZV file with us? Feel free to directly message to me if you are unable to share it publicly. We will get to the bottom of this! :t_rex:

Hello Matthew,
Thank you for getting back to me :slight_smile: I've attached the QZV file.
In case it's relevant, I'm running a virtual box with qiime2-2017.10

alpha-rarefaction.qzv (317.4 KB)

Thanks @Analysis_Ant! Looks like you found a bug! :bug: I opened an issue on the appropriate issue tracker to track the development of a fix. The bug appears to be related to spaces in your metadata category names. If you rename them to something without spaces:

Collection Site -> CollectionSite or Collection_Site

the visualization should be a bit better behaved. Hopefully that gets you moving in the near-term - stay tuned for a bug fix! Thanks! :t_rex:

1 Like

That fixed it :smiley:
Thank you for looking into this during the holidays.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.

QIIME 2 2018.2 is out now, and includes a bug fix for this particular issue, as well as a few other enhancements and improvements to this visualization.