Alpha Diversity observed_otu Not Working in last 3 qiime releases

I was running alpha diversity observed otu's, and I have gotten a plug-in error using both 2021.2, 2021.4, 2020.8

I have used this code in the 2020.6 release and it worked fine.

This is the code block I used:

qiime diversity alpha
--i-table table.qza
--p-metric observed_otus
--o-alpha-diversity table-alpha-richness.qza

Hi @carolina!

We need a bit more information in order to effectively support you - can you please include the output that you see when you get the error? Either re-run the command with the --verbose flag, or copy-and-paste the error log file.

Also - are you seeing the same error in each version of QIIME 2, or different errors?



(1/1) Invalid value for '--i-table': 'V34_merged_dada2_biom_sepp_silva128_onl
qza' is not a QIIME 2 Artifact (.qza)


observed_otu > Plugin error from diversity:Parameter 'metric' received 'observed_otus' as an argument, which is incompatible with parameter type:Str %

faiths_pd > no error
shannon > no error

observed_otu > Plugin error from diversity:Parameter 'metric' received 'observed_otus' as an argument, which is incompatible with parameter type: Str %

faiths_pd > no error
shannon > no error

observed_otu > no error
faiths_pd > no error
shannon > no error

Hi @carolina, and welcome to the forum! It looks like you've got two different error messages. Those are always the best place to start with troubleshooting.

What do you think that error message means? Hint: your error message looks incomplete. You omitted the "choices" section after the %:

This one seems to indicate your table is not a "real" .qza. I'm not sure whether it's possible for that to pop up if you have a bad filepath, but that's where I'd start. Please make 110% sure you've correctly spelled that very long file path. If that doesn't fix the error message, please share the details on how you made that FeatureTable and we can look into it further.

  • The command I wrote does not exist, so I see that the name has been changed. This would be good to update on the tutorials.

-As for it not being a "real" qza. I used the same table across the different versions and it worked, but does not work in the 2021 versions. I am not sure how I should proceed.

Only usable "Choices" should show up in the command-specific documentation or when accessing help through the command line interface, but it's totally possible we overlooked something in the tutorials. I wasn't able to find any uses of observed_otus in the tutorial source code, but if you have an error in mind, I'd love to fix it. Please let me know where you encountered the issue.

If you can, please share the FeatureTable you believe to be faulty and the exact commands you are trying to run. I'll try to reproduce on my end and we can go from there.

I tried uploading the file, but it is to big even when zipped. How should I proceed with sending it your way?

Let's take a step back first. Try running qiime tools validate on the file that's breaking. I suspect it may have become corrupted somehow, and that may give us some useful feedback.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.